Closed Bug 1003375 Opened 6 years ago Closed 2 years ago

[B2G][Tarako][Settings]Fixed Dialing Numbers does not enable when SIM is inserted in SIM PIN 2 slot and enable is selected

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(3 files)

Attached file Firewatch Log
User inserts a SIM in SIM PIN 2. User starts device and taps Settings App. User selects Call Settings, SIM PIN 2, and Fixed dialing numbers. When user toggles the Fixed dialing numbers option from off to on, the blue lit radio button displays. However, beneath Fixed dialing numbers, it remains labeled Disabled. 

Prerequisites:
Insert SIM in SIM PIN 2 only 

Repro Steps:
1) Updated Tarako to BuildID: 20140429014002
2) Tap Settings and select Call Settings
3) Tap SIM PIN 2 and Fixed dialing numbers
4) Tap the radio button toggler to right of Fixed dialing numbers

Actual:
The blue lit radio button displays but the text beneath Fixed dialing numbers shows as Disabled

Expected:
The blue lit radio button displays with the text listed as Enabled and user is able to proceed to the next screen to complete the enable process 

Notes: 
Repro frequency: 10/10 – 100 percent 

See attached: Logcat, Firewatch, Video Clip = https://www.youtube.com/watch?v=4C57SOgfw_c

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140429014002
Gaia: b5adc5a943d3abbd6ab070a47c847f2c24891cc5
Gecko: e9890f5d4709
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does not reproduce on 1.3 Buri as this device does not have dual SIM capability.

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140429024001
Gaia: caab7a78f0c04913f48a3051259663ee85625906
Gecko: f84a8ffbc552
Version: 28.0
Firmware Version: v1.2-device.cfg
Can you turn on the ril.debugging.enabled and then redo the logcat with "adb logcat -b radio" please?
https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Changing_preferences
Flags: needinfo?(mclemmons)
Also we should check with a fugu or another dsds device.  buri won't show this issue since it only has one sim card.
Attached file Logcat RIL Enabled
Please see attachment with requested information uploaded.
Flags: needinfo?(mclemmons)
Eric - Can you check if this happens on 1.3 Fugu device?
Flags: needinfo?(echang)
Same on v1.3 Fugu, 

v1.4 Dolphin.
It prompts for PIN2, and shows "Enable" below the FDN, as it is on Buri.

### v1.3 on  <Fugu>
Your Target Build: B2G.v1.3.0.fugu                                           
Gaia      667539f1ed4becc45b182a5f1046221d3eeb9e7c
Gecko     96a1d0f4c58e09b4f1c38df79e099df08eb147d1
BuildID   20140505101103                  
Version   28.0    
                        
### v1.4 on <Dolphin>
Your Target Build: B2G.v1.4.0.dolphin     
Gaia      fccb15d6940db51615545574877a62d69406b1c2
Gecko     3ed3bbf1941e608bc9630942c7063a8b818f36bc
BuildID   20140505085052                  
Version   30.0
Flags: needinfo?(echang)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.