Closed Bug 1003458 Opened 5 years ago Closed 5 years ago

[B2G][Tarako]Facebook closes when loading additional posts to the feed

Categories

(Firefox OS Graveyard :: Performance, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 998145
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: JMercado, Assigned: Harald)

Details

(Keywords: memory-footprint, perf, Whiteboard: [tarako-exploratory][MemShrink][c=memory p= s= u=tarako])

Attachments

(2 files)

Description:
When scrolling through the Facebook feed, the app will often close when it attempts to load more tweets.  This does not necessarily occur on every load, but will eventually occur if enough posts are loaded.
Clicking a specific post seems to delay this close.
Prerequisites: Have an active Facebook account.

Repro Steps:
1) Update a Tarako to BuildID: 20140429014002
2) Open and sign into Facebook
3) Scroll through until additional posts load taking care to avoid opening any specific post
4) Repeat step 3 until the app closes

Actual:
Facebook will close after loading more posts.

Expected:
Facebook does not close when scrolling through posts.

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140429014002
Gaia: b5adc5a943d3abbd6ab070a47c847f2c24891cc5
Gecko: e9890f5d4709
Version: 28.1
Firmware Version: sp6821

Notes: This is very similar to bug 1003317 but consistently takes more additional loads to occur (5-7 loads compared to 2-4 loads).

Repro frequency: 100%
See attached: logcat, firewatch report, video
This issue does not occur on 1.3 Buri.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140425024003
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf
Gecko: c96b0cf6343f
Version: 28.0
Firmware Version: v1.2-device.cfg

Additionl posts load without the app closing.
Blocks: b2g-facebook
Component: Gaia → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Per discussion on other bugs - FB apparently is a must have for Tarako, so I'm bouncing this over to the perf component for perf evaluation.
No longer blocks: b2g-facebook
blocking-b2g: --- → 1.3T?
Component: Preinstalled B2G Apps → Performance
Keywords: footprint, perf
Product: Tech Evangelism → Firefox OS
Whiteboard: [tarako-exploratory] → [tarako-exploratory][MemShrink]
(In reply to Jason Smith [:jsmith] from comment #4)
> Per discussion on other bugs - FB apparently is a must have for Tarako, so
> I'm bouncing this over to the perf component for perf evaluation.

See https://bugzilla.mozilla.org/show_bug.cgi?id=998145#c16
chances are we need profiling.
Flags: needinfo?(nhirata.bugzilla)
Keywords: qawanted
triage: 1.3T+ as facebook is required for Tarako
blocking-b2g: 1.3T? → 1.3T+
I think this might be a dup of bug 998145 ?
Flags: needinfo?(nhirata.bugzilla)
Hi,

I check the log and found it might be low memory caused.

=== log ===
04-29 12:06:27.020   443   443 I log     : <4>0[ 89.293828] lowmem_shrink select 412 (Browser), adj 10, size 8042, to kill 

04-29 12:06:27.020   443   443 I log     : <4>0[ 89.293828] lowmem_shrink select 412 (Browser), adj 10, size 8042, to kill 

04-29 12:06:34.060   467   467 I log     : <4>0[ 96.337269] lowmem_shrink select 435 (Browser), adj 10, size 7964, to kill 

=== log ===

 
Who can analyze attached logs and figure out what's going on this issue?
Keywords: qawanted
Priority: -- → P1
Whiteboard: [tarako-exploratory][MemShrink] → [tarako-exploratory][MemShrink][c=memory p= s= u=tarako]
per https://bugzilla.mozilla.org/show_bug.cgi?id=998145#c20, I'm closing this as a dup
Assignee: nobody → hkirschner
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 998145
You need to log in before you can comment on or make changes to this bug.