Closed Bug 1003597 Opened 5 years ago Closed 5 years ago

[B2G][Browser][Tarako] When accessing a website without wifi the user sees an incorrect error message

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED FIXED
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: dharris, Assigned: fzzzy)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Logcat, Firewatch
Description:
Disabling wifi does not stop the user from viewing pages they have recently viewed on the internet. If the user tries to view something they had not viewed before wifi was disabled, an incorrect error message is displayed

Repro Steps:
1) Update a Tarako to BuildID: 20140429014002
2) Open browser app> Go to youtube.com> Close browser
3) Turn off wifi in settings, or the notification tray
4) Open the browser app> Go to youtube.com> tap on a video

Actual:
User gets an error that says "invalid response recived"

Expected:
As soon as the user opens youtube.com they get an error that says they need an internet connection to view this page

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140429014002
Gaia: b5adc5a943d3abbd6ab070a47c847f2c24891cc5
Gecko: e9890f5d4709
Version: 28.1
Firmware Version: sp6821

Keywords: access, cache, view, loading, improper, wrong

Repro frequency: 100%
See attached: Logcat, Firewatch, Video - http://youtu.be/vHfJG9s1ZUo
This issue does not occur on Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140429024001
Gaia: caab7a78f0c04913f48a3051259663ee85625906
Gecko: f84a8ffbc552
Version: 28.0
Firmware Version: v1.2-device.cfg
Do you have SIM data turned on?  Otherwise, I would think it might be due to cached data and it might be the part of the html that's still cached that is trying to run...
Flags: needinfo?(dharris)
SIM data is not on.
Flags: needinfo?(dharris)
The video here doesn't really describe the bug here effectively. Can we get a new video that shows the bug in a more clear fashion?
Keywords: qawanted
Attached image ErrorScreenCap.png
Attached a screen shot of the error that is shown at the end of the original video. The resolutions of the video cameras we have available make the error very difficult to see in the recordings.

Screen shot attached: ErrorScreenCap.png
Keywords: qawanted
TE problem.
Blocks: b2g-youtube
Component: Gaia::Browser → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Unable to reproduce on Tarako.  My message says "Unable to connect - Firefox can't establish a connection to server at m.youtube.com"
Assignee: nobody → dpreston
Status: NEW → ASSIGNED
Priority: -- → P2
On my tarako build from 5/7, following the repro steps produce the expected error message about the network not being available.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.