bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Install.exe does not run if COMCTL32.DLL version is 4.0 in Win95

VERIFIED FIXED in M9

Status

SeaMonkey
Installer
P2
major
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Tested 7-16 Win32 build.

Install.exe does not run under Win95 (4.00.950 and 4.00.950A).
Win95 (4.00.950 and 4.00.950A) has COMCTL32.DLL 4.00 version.

When you click on Install.exe, the error "The SETUP.EXE file is linked to missing export
COMCTL32.DLL: InitCommon ControlsEX." message shows up.  Install.exe cannot be run.

I checked the version of COMCTL32.DLL is 4.00.
I checked this on the different machines.  INSTALL.EXE runs with COMCTL32.DLL version 4.7.
It seems that Windows 95 service pack 2 or better has this file.

http://client/seamonkey/prd/seamonkey_platforms.htm
does not say which Windows 95 service pack supports.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M9
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
I have already updated the install code to not need comctl32.dll anymore.  I
will check it in along with other features when I'm done.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
fix is checked in.

Comment 3

19 years ago
Teruko,
Will you verify this?  I have the correct version of comctl32.dll on my machines
and cannot reproduce.

thanks,
Grace
(Reporter)

Updated

19 years ago
QA Contact: gbush → teruko
(Reporter)

Comment 4

19 years ago
Changed QA contact to teruko@netscape.com.  Today's build (7-28-09) did not get this fix.
I will verify this in next build.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
I verified this in 7-29-08 Win32 build.

Comment 6

19 years ago
Updating component from Install Wizard to Installer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.