Closed Bug 1003767 Opened 6 years ago Closed 6 years ago

[NFC] Could not share contacts which with photo

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S1 (9may)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: ashiue, Assigned: mbudzynski)

References

Details

Attachments

(1 file)

Gaia      db3bcec51a361daddb7d3d4ba4d8a2a664b7b6aa
Gecko     https://hg.mozilla.org/mozilla-central/rev/90267d87c375
BuildID   20140429160215
Version   32.0a1


Two phones(Device A, Device B) with NFC
Device A has some contacts information (with photo)

STR:
1. Enable NFC in settings
2. Device A open specific contact info
3. Touch two phones together
4. Swipe screen on Device A to share specific contact

Expected result:
Device B receive contact info shared by Device A

Actual result:
Device B receive nothing
Hi Ben, does BT support Object Push Profile for vCards now?
blocking-b2g: --- → 2.0?
Flags: needinfo?(btian)
Yes, BT supports transfer of contact info. NFC receiver should then associate the file with contact app and open it automatically.
Flags: needinfo?(btian)
If the contact includes a picture or large huge data, we should use handover mechanism and enable BT for this contact sharing. But I wonder if NFC manager has done this. Sid, can you confirmed that?
Flags: needinfo?(psiddh)
(In reply to Ken Chang[:ken] from comment #3)
> If the contact includes a picture or large huge data, we should use handover
> mechanism and enable BT for this contact sharing. But I wonder if NFC
> manager has done this. Sid, can you confirmed that?
After checking NFC manager, I think we can use the same way as sending video method to send a contact with image through BT.
Ok, we did some testing on Android devices today.
One Android device tries to share a contact (with photo) to another one using NFC.
We observed that the contact was shared successfully to the other device (but without the photo)

This kind of make sense as stringing BT transfer (of photo) with a regular 'ndef push of vCard' can be tricky affair.

However at-least the vCard of the contact minus the photo should have been shared on FxOS phones.
That could be an issue. I think, picture / photo not being transferred is a non-issue if compared with Android
Flags: needinfo?(psiddh)
Contact information excluding photo shall be transferred.
ni? Juwei for confirmation if we can live without profile photo being shared.
Profile photo is not specified in user story.
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(jhuang)
Component: NFC → Gaia::Contacts
Flags: needinfo?(mbudzynski)
I'm on it now.
Flags: needinfo?(mbudzynski)
Assignee: nobody → mbudzynski
Patch attached - I introduced new argument in Contacts2VCard function called 'skipPhoto', when 'true' the vcard won't contain any photo data so we will be able to share it via NFC without any problems. When argument is skipped it will behave like before, so it's backwards compatible (tested with exporting & importing contacts to/from the sdcard).
Attachment #8417972 - Flags: review?(bkelly)
Ben, can you? You are the only contacts peer available this week :)
Comment on attachment 8417972 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18986

One minor nit on github, but otherwise this looks good.

Unfortunately I don't have nfc setup locally, so I can't test.  The new unit test looks like it should provide coverage of the conversion routine.

Assuming you have verified this yourself, then r=me.
Attachment #8417972 - Flags: review?(bkelly) → review+
Thanks a lot Ben, I know it was hard to make 4 quite big reviews in one day but I'm glad you did it :)!

Patch landed in master https://github.com/mozilla-b2g/gaia/commit/96c480cce3f439cdf3acccc81072cd7adad17b96
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
So in my understanding, there are two options:
1) We transfer contact without profile photo
1) Profile photo is available to transfer but we use BT to transfer it

In UX perspective, I would recommend to transfer the complete contact profile to one another. 
But if it's not in scope of 2.0, I'm ok with skip this part for now.
Flags: needinfo?(jhuang)
(In reply to Juwei Huang from comment #12)
> So in my understanding, there are two options:
> 1) We transfer contact without profile photo
> 2) Profile photo is available to transfer but we use BT to transfer it
> 
> In UX perspective, I would recommend to transfer the complete contact
> profile to one another. 
> But if it's not in scope of 2.0, I'm ok with skip this part for now.
Thanks for the comments.
I believe we are doing #1, and should plan #2 together with batch sharing in future version.
What do you think?
Target Milestone: --- → 2.0 S1 (9may)
Verified on
Gaia      347d0517f0a77122c876d5f62c0942006a7a0bfe
Gecko     https://hg.mozilla.org/mozilla-central/rev/8be0e21fd300
BuildID   20140507160203
Version   32.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.