Closed Bug 1003821 Opened 9 years ago Closed 5 years ago

santander.cl sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hsteen, Assigned: ravmn, Mentored)

References

()

Details

(Whiteboard: [country-cl][clientsniff][sitewait])

Attachments

(1 file)

Attached image comparison screenshot
The santander.cl site intends to send mobile phones to a mobile site, but fails to detect Firefox OS devices as smartphones.

The JavaScript-based browser detection is found in 

http://santander.cl/include/js/reemplazo_home_redireccion.js

and this is the code:

var ismobile=navigator.userAgent.match(/(iPhone)|(iPad)|(Android)|(BlackBerry)/i); 
var origen=document.getElementById("menu");
 
	
if (ismobile != null) {  
	if (navigator.userAgent.match(/(Android)|(iPhone)|(iPad)/i) == null) {   
		document.location='http://www.santandermovil.cl/moviles/login.aspx';
	}
	else {
		if (origen != 1 ) {
			if(navigator.userAgent.match(/(Android)/i)) {
				document.location='http://www.santander.cl/movil/menu_movil.html';
			} else if (navigator.userAgent.match(/(iPhone)|(iPad)/i)) {
				document.location='http://santander.cl/movil/menu_iphone.html';
			}
		}
	}
}
This is a bank Web site. We might have harder time to find someone.
Let's see.

Maybe sudeep pankaj can help us find the right person.
PHP Developer at Santander
http://www.linkedin.com/in/skpankaj
@skpankaj
Duplicate of this bug: 1004644
Assignee: nobody → ravmn
Mentor: hsteen
Whiteboard: [country-cl][clientsniff][contactready][mentor=hsteen] → [country-cl][clientsniff][contactready]
As the contact form for clients doesn't work, tried to contact via Twitter
Hardware: All → ARM
Whiteboard: [country-cl][clientsniff][contactready] → [country-cl][clientsniff][sitewait]
Status: NEW → ASSIGNED
Received no answer from the official Twitter account. Just sended an e-mail to the technical contact from  http://nic.cl/registry/Whois.do?d=santander.cl
Priority: -- → P5
Not necessary anymore
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.