[B2G][Browser][Tarako] When adding a web page to the home screen the browser app experiences a pitfall

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: dharris, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory], )

Attachments

(1 attachment)

Posted file Logcat, Firewatch
Description:
When trying to add a website to the home screen 2 times within a short period of time, the user will experience a pitfall in which they cannot leave the page they are on with the UI that is given

Prerequisites: Have wifi connected and enabled

Repro Steps:
1) Update a Tarako to BuildID: 20140429014002
2) Open Browser app
3) Go to a website (Youtube, facebook, hotmail etc.)
4) Tap on the star on the bottom right> tap 'add to home screen' while the page is loading
5) Tap on either the 'X' or 'Add to Home Screen'
6) Quickly repeat step 4

Actual:
The user is able to type in the WEBSITE NAME, and ADDRESS fields, but is not able to tap 'Add to Home Screen' and the 'X' is unresponsive.

Expected:
The user is able to Add the page to the home screen, or 'X' out of this page without issue

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140429014002
Gaia: b5adc5a943d3abbd6ab070a47c847f2c24891cc5
Gecko: e9890f5d4709
Version: 28.1
Firmware Version: sp6821


Keywords: Website, Stuck, Greyed out, Loading


Notes: The User can return to the homescreen, or close the Browser app and retry. This issue is hard to repro on web pages that load quickly such as google.com


Repro frequency: 95%
See attached: Logcat, Firewatch, Video - https://www.youtube.com/watch?edit=vd&v=0RCHnsbJvxc
Issue above does not occur on Buri 1.3


1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140429024001
Gaia: caab7a78f0c04913f48a3051259663ee85625906
Gecko: f84a8ffbc552
Version: 28.0
Firmware Version: v1.2-device.cfg
I can't reproduce this issue right after a reboot; looking at the firewatch log, it looks like the processor is overworked.  Seems like a lot of stuff has been done to get to the point where this bug occurs... is that right?
Flags: needinfo?(dharris)
I was able to reproduce this bug directly after a phone restart, and a fresh reset using the STR originally given
Flags: needinfo?(dharris)
Christian, is this dialog part of the bookmarks app or is it still part of the homescreen app in 1.3T?
Flags: needinfo?(crdlc)
If this is not done in quick succession, can this still be reproduced?
Keywords: qawanted
I was able to reproduce this issue with the original steps after 3 attempts and talking with the reporter. 

Slowing the steps down I was unable to reproduce the issue after about 25 tries.

1.3t Environmental Variables:
Device: Tarako 1.3t MOZ
BuildID: 20140430014008
Gaia: f9b62bd1135f4edf8317fff1c2947b9d99438d79
Gecko: ba50f734b815
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29
Keywords: qawanted
The new architecture for Bookmarks only lives in 2.0 Ben, so the bookmarks are still part of the homescreen app in 1.3T

(In reply to Ben Francis [:benfrancis] from comment #4)
> Christian, is this dialog part of the bookmarks app or is it still part of
> the homescreen app in 1.3T?
Flags: needinfo?(crdlc)
Then it sounds like homescreen is most likely where this bug is lurking. Please move it back if that isn't the case.
Component: Gaia::Browser → Gaia::Homescreen
I cannot assign me it to myself because I do not have a Tarako device where the bug is reproducible according to flags.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.