Closed Bug 1003992 Opened 5 years ago Closed 5 years ago

[B2G][Tarako][Camera]Attempted attach camera image to Contacts causes Homescreen to appear unexpectedly

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

User taps Contacts App, adds a new contact with first and last name only, and selects to add a picture using camera. After taking a photo and choosing select, the screen goes black with briefly a rotating clockwise blue arrow. Then the arrow vanishes and either the screen stays black with status bar showing or user returned to the homescreen and the image is not added to the contact.

Repro Steps:
1) Updated Tarako to BuildID: 20140429014002 
2) Tap Contacts App
3) Enter first and last name for contact and select Add picture
4) Take photo and choose select

Actual:
In five attempts, four times the screen goes black with the status bar showing then a blue spinning clockwise circle appears before screen goes black again and transitions to the homescreen. In those same five attempts, once the screen goes black with the status bar showing then a blue spinning clockwise circle appears before screen goes black again and stays that way indefinitely. 

Expected:
Photo taken is added to Contact and user returns to the Contact App edit screen

Notes: 
Repro frequency: 5/5 – 100 percent 

See attached: Firewatch, logcat, video clip = https://www.youtube.com/watch?v=FqSGV5MB-CE

Environmental Variables: 
Device: Tarako 1.3T MOZ 
BuildID: 20140429014002 
Gaia: b5adc5a943d3abbd6ab070a47c847f2c24891cc5 
Gecko: e9890f5d4709 
Version: 28.1
Firmware Version: sp6821a-gonk4.0-4-29
This issue does not reproduce on 1.3 Buri. Following Comment 0's STR adds the photo to the Contact and does not display the black screen, rotating arrow or homescreen sequence experienced with 1.3 Tarako.

Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140429024001 
Gaia: caab7a78f0c04913f48a3051259663ee85625906 
Gecko: f84a8ffbc552 
Version: 28.0
Firmware Version: v1.2-device.cfg
Attached file Firewatch log
looking at the video, it looks like the apps were LMK'ed.
blocking-b2g: --- → 1.3T?
Isn't the root cause of the problem here that the build tested here doesn't contain what's done in bug 1000448
blocking-b2g: 1.3T? → ---
Flags: needinfo?(nhirata.bugzilla)
Ah good point.  mclemmons, can you retest please on today's build?
Flags: needinfo?(nhirata.bugzilla) → needinfo?(mclemmons)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> Ah good point.  mclemmons, can you retest please on today's build?

Following the STR from Comment 0 on today's build, user unable to reproduce the reported behavior. After 15 attempts, each time the photo taken was added without the unexpected behavior of staying on a black screen indefinitely or force closing the app and returning to the homescreen. 

Environmental Variables:
Device: Tarako 1.3 MOZ
BuildID: 20140501014002
Gaia: d26a776beae0070b0032248a2ce482bbe6321a6d
Gecko: e90f4b655511
Version: 28.1
Firmware Version: sp6821a-gonk4.0-4-29
Flags: needinfo?(mclemmons)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.