Closed Bug 1004036 Opened 6 years ago Closed 4 years ago

clearing of notifications fade during drag

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
FxOS-S7 (18Sep)

People

(Reporter: dietrich, Assigned: anubhav.worklinux, Mentored)

Details

(Whiteboard: [lang=js][contrib-bzrand])

Attachments

(1 file)

Clearing notifications feels disconnected - almost like you think it's not working, until it does. It is very unsatisfying.

I think the problem is that the notifications do not respond kinetically.

Android's notifications have a fantastic kinetic response, combined with a fade, which makes the gesture unambiguous as to what it does and whether it's working. 

The gesture is undiscoverable on either OS, but that's for a different bug ;)
Someone fixed the kinetic part!

Changing to add a fade, just for fun :)
Mentor: dietrich
Summary: clearing of notifications should slide kinetically → clearing of notifications fade during drag
Whiteboard: [lang=js]
Hi! I would like to Work on this bug. Could you just give me some pointers on how to start.
thanks!
Great! Here's the bug that added the animation to the clearing of notifications:

https://bugzilla.mozilla.org/show_bug.cgi?id=1092536

Take a look at the patch there. I haven't looked through that patch, but likely you'll need to add to the existing animation, making the notification fade during the transition.
will take a look at the bug surely! thanks!
Assignee: nobody → anubhav.worklinux
Attachment #8652964 - Flags: review?(dietrich)
Comment on attachment 8652964 [details] [review]
[gaia] anu7495:fadefix > mozilla-b2g:master

f+ from me on the general approach, but I haven't tested yet, and am not an official reviewer of this code, so cannot give r+.

Would be rad if you could submit a gif or video of what this looks like in practice. That will make getting ui+ easier.
Attachment #8652964 - Flags: ui-review?(firefoxos-ux-bugzilla)
Attachment #8652964 - Flags: review?(dietrich)
Attachment #8652964 - Flags: feedback+
Etienne, who can review this?
Flags: needinfo?(etienne)
Eric - is this something you could possibly UI-review? Totally cool if not, but I thought I would ping since you've been doing notification stuff and then it doesn't sit until next week's triage.
Flags: needinfo?(epang)
Dietrich, i can submit a gif or video but i dont know how. can i get notifications in a B2G build or i need a device for that.
(In reply to Dietrich Ayala (:dietrich) from comment #7)
> Etienne, who can review this?

:albertopq is a good candidate!

Nit: the notification could fade while you're dragging it with your finger too :)
Flags: needinfo?(etienne)
(In reply to anubhav.worklinux from comment #9)
> Dietrich, i can submit a gif or video but i dont know how. can i get
> notifications in a B2G build or i need a device for that.

Yes, you can get notifications in a desktop build or Mulet or even in simulator in WebIDE. See:

https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Different_ways_to_run_Gaia

You can trigger a notification using the notifications API:

https://developer.mozilla.org/en-US/docs/Web/API/notification

(In reply to Etienne Segonzac (:etienne) from comment #10)
> Nit: the notification could fade while you're dragging it with your finger
> too :)

YES this is the ideal behavior, but cannot fade too early.
Attachment #8652964 - Flags: review?(apastor)
Comment on attachment 8652964 [details] [review]
[gaia] anu7495:fadefix > mozilla-b2g:master

The code looks good to me! Thanks for fixing this!
Attachment #8652964 - Flags: review?(apastor) → review+
Comment on attachment 8652964 [details] [review]
[gaia] anu7495:fadefix > mozilla-b2g:master

Moving review to Eric. Thanks for pinging the UX team!
Attachment #8652964 - Flags: ui-review?(firefoxos-ux-bugzilla) → ui-review?(epang)
Comment on attachment 8652964 [details] [review]
[gaia] anu7495:fadefix > mozilla-b2g:master

R+
This looks great to me, thanks for working on it! :)
Flags: needinfo?(epang)
Attachment #8652964 - Flags: ui-review?(epang) → ui-review+
Keywords: checkin-needed
Whiteboard: [lang=js] → [lang=js][contrib-bzrand]
https://github.com/mozilla-b2g/gaia/commit/9d99f5d807444040209b9786032b7a53881f827e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S7 (18Sep)
(In reply to Dietrich Ayala (:dietrich) from comment #11)
> (In reply to Etienne Segonzac (:etienne) from comment #10)
> > Nit: the notification could fade while you're dragging it with your finger
> > too :)
> 
> YES this is the ideal behavior, but cannot fade too early.

Filed bug 1203214 for this behavior.
Thanks for taking this bug to the finish line, Anubhav! I added you to the list of Friends of Mozilla, so you'll get a big public thanks at the weekly project meeting next Monday :)

https://wiki.mozilla.org/WeeklyUpdates/2015-09-14#Friends_of_Mozilla
Thanks! It was my pleasure.
You need to log in before you can comment on or make changes to this bug.