Closed Bug 1004327 Opened 5 years ago Closed 5 years ago

input type=number limited to 3 digits of precision

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla32
Tracking Status
firefox30 --- verified
firefox31 --- verified
firefox32 --- verified
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: owen, Assigned: jwatt)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140428193603

Steps to reproduce:

See: http://jsfiddle.net/LAk5C/
Create an Input control of type=number with greater than 3 decimal digits step & value
<input type="number" name="test" step="0.0001" value="1.1111">



Actual results:

Only shows 3 digits of precision, regardless of step or initial value precision:
Above example shows: 1.111
Internal value steps correctly but display changes only every 10 steps because of rounding to 3 decimal places



Expected results:

Not sure what the HTML5 spec says but I think if display value must be rounded then it should never be truncated to a lower precision than the step value.
Status: UNCONFIRMED → NEW
Component: DOM: Core & HTML → Layout: Form Controls
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 29 Branch → Trunk
Attached patch patchSplinter Review
Assignee: nobody → jwatt
Attachment #8415826 - Flags: review?(bzbarsky)
https://hg.mozilla.org/mozilla-central/rev/5fcd868dccc6
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Will this be uplifted to Aurora & Beta?
Comment on attachment 8415826 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 844744
User impact if declined: some site's use of <input type=number> will be broken
Testing completed (on m-c, etc.): landed on m-i
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8415826 - Flags: approval-mozilla-beta?
Attachment #8415826 - Flags: approval-mozilla-aurora?
Attachment #8415826 - Flags: approval-mozilla-beta?
Attachment #8415826 - Flags: approval-mozilla-beta+
Attachment #8415826 - Flags: approval-mozilla-aurora?
Attachment #8415826 - Flags: approval-mozilla-aurora+
Whiteboard: verifyme
Verified as fixed on Firefox 30 beta 2 (20140505140302), Aurora 31.0a2 (20140505004003) and Nightly 32.0a1 (20140505030202) under Win 7 64-bit, Ubuntu 12.10 32-bit and Mac OSX 10.7.5
Status: RESOLVED → VERIFIED
QA Contact: petruta.rasa
Whiteboard: verifyme
Chances are probably very slim and maybe it's already too late, but I give it a try anyway.

There is going to be a maintenance update of Firefox 29. Any chance to get this included?
It is indeed too late, sorry. The next version is not too far anyway.
Depends on: 1010184
Duplicate of this bug: 1012446
Duplicate of this bug: 1012976
You need to log in before you can comment on or make changes to this bug.