Closed Bug 1004488 Opened 8 years ago Closed 8 years ago

Page has wrong zoom level after pressing BACK button

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1002426

People

(Reporter: mfinkle, Assigned: esawin)

Details

STR:
1. Start Fennec
2. cnn.com (the desktop version should load)
3. After page fully loads, tap a link to an article
4. Let article fully load. Do not change the zoom level.
5. Press BACK button

Expected: cnn.com page appears at the previous zoom level

Actual: cnn.com loads, but the page is zoomed

I can get this to happen with other desktop style webpages in step #2, not just cnn.com.
It is very reproducible if you always start Fennec fresh. Tapping desktop-style links from the Top Sites page causes this to happen too, but only reliably on a fresh start.
bug 1002426? Is 30 or 31 affected?
OS: Linux → Android
Hardware: x86_64 → All
Assignee: nobody → esawin
This is caused by resolution overriding with the default value, like in bug 1002426.
When we don't scroll or zoom on a page, we don't save the scroll frame session, which leads to this issue when restoring from the default values.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1002426
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.