Closed Bug 1004890 Opened 6 years ago Closed 6 years ago

Add UI telemetry for the Home Page contextmenu

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox31 --- verified
firefox32 --- verified

People

(Reporter: mfinkle, Assigned: mfinkle)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Simple patch that logs an event for any Home Page contextmenu action. The Android resource name for the action is sent as an Extra.
Attachment #8416304 - Flags: review?(rnewman)
Comment on attachment 8416304 [details] [diff] [review]
uitelemetry-home-contextmenu v0.1

Review of attachment 8416304 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8416304 - Flags: review?(rnewman) → review+
needinfo'ing myself to document this.
Assignee: nobody → mark.finkle
Status: NEW → ASSIGNED
Flags: needinfo?(rnewman)
OS: Linux → Android
Hardware: x86_64 → All
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #4)
> Backed out because Android Armv6 robocop-1 went perma-fail starting with
> this push.
> https://hg.mozilla.org/integration/fx-team/rev/fb88b8685827
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=38947512&tree=Fx-Team

Try run was green. Retriggers of the two failing rc1 runs were both green. Two pushes that completed before the backout were both green.

Relanding: https://hg.mozilla.org/integration/fx-team/rev/62ead59d3f19
https://hg.mozilla.org/mozilla-central/rev/62ead59d3f19
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8416304 [details] [diff] [review]
uitelemetry-home-contextmenu v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: We miss out on some "before changes" telemetry that could show affect of Fx32 changes
Testing completed (on m-c, etc.): Working on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8416304 - Flags: approval-mozilla-aurora?
Attachment #8416304 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in builds:
- 32.0a1 (2014-05-29);
- 31.0a2 (2014-05-29);
Device: Samsung Galaxy Nexus (Android 4.2.1).
Status: RESOLVED → VERIFIED
Flags: needinfo?(rnewman)
You need to log in before you can comment on or make changes to this bug.