Closed Bug 100490 Opened 22 years ago Closed 22 years ago

[Bugzilla] bug ID used over search term if javascript disabled. Incorrect error message

Categories

(Bugzilla :: Query/Bug List, defect, P3)

2.10
defect

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: coffeebreaks, Assigned: afranke)

References

()

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

NOTE: I was not able to fill a bug for Bugzilla so I've put that one in
Browser-General even if it's not its place. 
I've already filed bugs for Bugzilla, so I guess it is another bug to fill :) 
PLEASE MOVE THIS BUG TO THE RIGHT PRODUCT.


Bugzilla requires javascript to make its queries
If Javascript is disabled, if someone uses the search shortcut on Bugzilla's
main page, Bugzilla will use the entered keywords as IDs not as search terms.
Thus it will display an error message saying that the error number is incorrect. 
It should in fact detect that the search terms were not IDs and that javascript
must be enabled.


Reproducible: Always
Steps to Reproduce:
1. Start Mozilla without javascript (I guess it does the same with IE)
2. Go to the web page, enter some keywords in the textbox (e.g. 'Bugzilla
search') and press enter
3. Bugzilla will display an error message saying that bug number is invalid.
4. enable javascript
5. back
6. press enter again. Same error (possible other bug? - see additional information)
7. back
8. press enter again. javascript is taken into account and search terms are
detected.

Actual Results:  The error message display that the bug ID is invalid. The
message is inexplicit.

Expected Results:  The error message contains a message saying that javascript
must be turned on.

There may be another bug hiden: the fact that going back after having enabled
javascript the first time doesn't work. But I am not sure.
correction:
'There may be another bug hiden: the fact that going back after having enabled
javascript the first time 'AND SEARCH AGAIN' doesn't work. But I am not sure.'

over to bugzilla
Assignee: asa → justdave
Component: Browser-General → Bugzilla-General
Product: Browser → Bugzilla
QA Contact: doronr → matty
Version: other → 2.10
See also bug 70907, "QuickSearch: port the JS code to perl (make it server-
side)".
Component: Bugzilla-General → Query/Bug List
This is my fault. Reassigning to me, confirming.
Assignee: justdave → afranke
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.16
Keywords: patch, review
Comment on attachment 50313 [details] [diff] [review]
fix: improve error message in CGI.pl (sub ValidateBugID)

r=kiko though I think this bug should have been either duped against the
main bug or WONTFIXED. Since you've clarified, I say get it in.

No second review seems to be needed.
Attachment #50313 - Flags: review+
r=gerv.

/cvsroot/mozilla/webtools/bugzilla/CGI.pl,v  <--  CGI.pl
new revision: 1.111; previous revision: 1.110

Gerv
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.