Closed Bug 1004931 Opened 7 years ago Closed 7 years ago

Australis: customize controls and buttons displayed off window

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 987586

People

(Reporter: flod, Unassigned)

Details

Attachments

(3 files)

Attached image Italian screenshot
This was originally reported on the Italian support forum from several users, in one case we managed to identify the cause in one extension (https://addons.mozilla.org/firefox/addon/sortcustomizationdialog/)

In Italian "Show/Hide toolbars" and "Restore defaults" have much longer labels, this extension adds elements near these controls. The result is that elements are displayed outside of the visible area, and in certain conditions (small monitors, low resolution, etc.) they can't be used.

Same thing happens in other locales (e.g. German, Spanish).
(In reply to Francesco Lodolo [:flod] from comment #0)
> Created attachment 8416364 [details]
> Italian screenshot
> 
> This was originally reported on the Italian support forum from several
> users, in one case we managed to identify the cause in one extension
> (https://addons.mozilla.org/firefox/addon/sortcustomizationdialog/)

Seems like that add-on should add it's search thingy in a separate line rather than cramming it next to the buttons.
(In reply to Dão Gottwald [:dao] from comment #2)
> Seems like that add-on should add it's search thingy in a separate line
> rather than cramming it next to the buttons.

I agree, not the smartest place to put stuff (I asked the user to report the bug also to the add-on author).

Having said that, I think we need a better way to cope with this. 

Also, we have at least one another case and haven't figured out yet the cause. I think it involves having gigantic Windows font and small resolution monitor, but haven't managed to reproduce it yet (on it).
(In reply to Francesco Lodolo [:flod] from comment #3)
> Also, we have at least one another case and haven't figured out yet the
> cause. I think it involves having gigantic Windows font and small resolution
> monitor, but haven't managed to reproduce it yet (on it).

If you are talking about about the labels in the help menu in the hamburger menu being cut off: This happens if you increase only the default font size in the system settings (at least on Windows 8.1).
Attached image Font 150%, 1280x960
I agree that this is a edge case, but this is what happens at 1280x960 with font set at 150%
We should let these buttons wrap, but that's not trivial. In any case, that issue is a duplicate of bug 987586, on which you are already CC'd, Francesco... (and which is already in the backlog)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987586
(In reply to Archaeopteryx [:aryx] from comment #4)
> (In reply to Francesco Lodolo [:flod] from comment #3)
> > Also, we have at least one another case and haven't figured out yet the
> > cause. I think it involves having gigantic Windows font and small resolution
> > monitor, but haven't managed to reproduce it yet (on it).
> 
> If you are talking about about the labels in the help menu in the hamburger
> menu being cut off: This happens if you increase only the default font size
> in the system settings (at least on Windows 8.1).

Please file a separate bug for this if it's reproducible after a restart, and outside customize mode. I'm not really sure how this breaks, because presumably the font size change would cause the menu panel to be bigger, too (it's sized in ems) so it's definitely a different issue.
(In reply to :Gijs Kruitbosch from comment #6)
> We should let these buttons wrap, but that's not trivial. In any case, that
> issue is a duplicate of bug 987586, on which you are already CC'd,
> Francesco... 

And I even searched :-\ (subject should probably be updated).

I remember that bug, but my mind didn't connect it to this one. Sorry to use is a dupe-finder.
You need to log in before you can comment on or make changes to this bug.