JAvaScript loops, CPU never rests

RESOLVED DUPLICATE of bug 13350

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 13350
17 years ago
11 years ago

People

(Reporter: Arthur, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4+) Gecko/20010915
BuildID:    2001091521

JavaScript seems to go into an endless loop.

Reproducible: Always
Steps to Reproduce:
1.Go to given URL
2.Cancel request for downloading plugin.
3.watch CPU load

Actual Results:  CPU load stays high

Expected Results:  Depending on what the Script intends to do. I don't think it
should keep running.

No plugins installed (neither flash nor java). JavaScript turned on, turning it
off solves the problem.
I don't see any endless loop.  My CPU usage is ~12% but that is presumably from
the flash movie on the left.  On mousing over the nav bars at the top my CPU
usage jumps to ~50% and is slow, but mousing off them promptly brings me back
down to ~12%.

Linux 2001091808 trunk.

Comment 2

17 years ago
There's an intentional loop in the inner (document) frame; here's an except from
the javascript code:

var delay_time = 10;

/* ... snip ... */

function reloc1()
{
/* ... snip ... */
}

function loopfunc1() {
        reloc1();
        setTimeout('loopfunc1()',delay_time);
}

So the function loopfunc1() will be call in a 10 ms interval.
(Reporter)

Comment 3

17 years ago
Eeek, that's using all the power of my 350MHz machine. It's ok to me to mark
this either invalid or making it an evangelism or performance bug. Would be nice
if one could shut off JavaScript for a page per mouseclick... Thank's for your
investigation.

Comment 4

17 years ago
Browser, not engine. Reassigning to DOM Level 0 - 
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 5

17 years ago
I believe this is a duplicate of bug 13350. Please reopen if you disagree -

*** This bug has been marked as a duplicate of 13350 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.