Closed Bug 1005078 Opened 7 years ago Closed 3 years ago

Sync Configuration - Configuration options are not honoured after selection on existing account

Categories

(Firefox for Android :: Android Sync, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected

People

(Reporter: aaronmt, Unassigned)

Details

(Keywords: reproducible)

Currently, when a user configures their preferred sync options (e.g, excluding history), that preference is not honoured after entering existing account credentials.

On new account, we honour a user's preferred customization.
Flags: in-moztrap?(fennec)
(In reply to Aaron Train [:aaronmt] from comment #0)
> Currently, when a user configures their preferred sync options (e.g,
> excluding history), that preference is not honoured after entering existing
> account credentials.
> 
> On new account, we honour a user's preferred customization.

Yep.  I'm assuming you mean: on sign up/sign in, you changed what to sync, then tapped I have an account.  We discard what to sync at that point, because what to sync is per Sync account, not per device, and when you're signing back in we think most users won't want to change what is synced for all devices.  Agreed that this is unintuitive and would appreciate your input on what you think would be better.

It is *very* tricky to most of the obviously better things, however, because we can't enforce your choices until you actually sync, which means that there's a race between all clients to be the first client to write your choices, and that race interacts with the email verification loop.

I believe we don't persist your what to sync choices if you tap sign in and then go back to sign up again.  Ditto for your age.  We might make this ticket smoothing that out.
Yes, this was on sign-in and agreed that it's not obvious. In my mind, I just wanted to bring in everything but history and was confused to see my history all of a sudden pop-up after first sync. I went back to check my Sync configuration options and it was indeed check-marked.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.