No pinch to zoom the web page on mac

RESOLVED DUPLICATE of bug 688990

Status

()

defect
RESOLVED DUPLICATE of bug 688990
5 years ago
5 years ago

People

(Reporter: garvan, Unassigned)

Tracking

({feature})

29 Branch
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
Platform: OS X 10.9

Safari, and some other built-by Apple applications (TextEdit) support pinching on the touchpad (or magic trackpad) to zoom the page larger or smaller. 

These apps appear to rasterize the view, smoothly zoom, and then use fractional font sizes to draw the final page to match exactly what the zoom preview looks like.

Chrome responds to pinch also, the pinch behaves like the shortcuts to increase/decrease font size.
This is more or less covered by bug 944938 but we should probably keep them separate for now because that one may end up not covering this, or we may want to fix this differently in the short term.
Depends on: 944938
Even if we just implement a stepwise zoom like Chrome does, it would be better than what we have now (which is no pinch-zooming at all).
Flags: firefox-backlog+
Bug 944938 has been fixed, but pinch-to-zoom functionality is still absent. This bug is possibly a duplicate of bug 688990. Garvan can you take a look into this?
Flags: needinfo?(gkeeley)
Reporter

Comment 4

5 years ago
Indeed is a duplicate of bug 688990.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(gkeeley)
Resolution: --- → DUPLICATE
Duplicate of bug: 688990
Flags: firefox-backlog+
You need to log in before you can comment on or make changes to this bug.