Closed Bug 1005128 Opened 6 years ago Closed 2 years ago

portalinmobiliario.com sends desktop site to Firefox OS and Firefox on Android

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hsteen, Assigned: lourdeslcastilloa, Mentored)

References

()

Details

(Whiteboard: [country-cl][serversniff][needscontact])

Attachments

(4 files)

This site intends to send mobile content to mobile browsers, however it doesn't detect Firefox OS devices as smartphones and sends desktop content instead. The HTTP traffic analysis below shows how the server-side browser logic works.

Safari on iPhone is redirected to http://m.portalinmobiliario.com/, Firefox OS and Firefox on Android are not redirected

Selected HTTP response headers (Firefox OS, Firefox on Android, Safari on iPhone):

Response for: 'Mozilla/5.0 (Mobile; rv:30) Gecko/30 Firefox/30'
Response Status: 200
content-length: 84731
content-type: text/html; charset=utf-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 200
content-length: 84810
content-type: text/html; charset=utf-8

Response for: 'Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25'
Response Status: 302
content-length: 149
location: http://m.portalinmobiliario.com/
content-type: text/html; charset=utf-8
Assignee: nobody → lourdeslcastilloa
I sent an email to info@portalinmobiliario.com
Whiteboard: [country-cl][serversniff][contactready][mentor=hsteen] → [country-cl][serversniff][sitewait][mentor=hsteen]
Mentor: hsteen
Whiteboard: [country-cl][serversniff][sitewait][mentor=hsteen] → [country-cl][serversniff][sitewait]
In accordance to https://groups.google.com/d/msg/mozilla.compatibility/OHsR590ExWs/W3ohc41tFAAJ
Requalifying the bug, the issue is happening on Firefox Android too.
OS: Gonk (Firefox OS) → Android
Hardware: All → ARM
Whiteboard: [country-cl][serversniff][sitewait] → [country-cl][serversniff][needscontact]
Status: NEW → UNCONFIRMED
Ever confirmed: false
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
fixed - android 6.0
Device information: Android 6.0
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.