Closed Bug 100529 Opened 19 years ago Closed 19 years ago

View source shows old source when submitting form using POST

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 55583

People

(Reporter: philip, Assigned: rods)

References

()

Details

When submitting a form using post, a view source shows previous source of the
form, that is stored in cache.

Reproduce it by going to http://www.ncst.ernet.in/~philip/test/test-form.cgi and
http://www.ncst.ernet.in/~philip/test/test-form.html

Both files provide two html forms, one using get, one using post.  Both submit
to test-form.cgi

Submit either using get, and then do a view source.

Expected: source should match display
What happens: source matches display

Now submit using post, and then do a view source
Expected: source should match display, or message should state that content is
from a POST submission
What happens: source matches the source in the first case.

Using Mozilla 0.9.4 on RHL7.1.  Installed from RPM.

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verifying
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.