Closed Bug 1005418 Opened 6 years ago Closed 6 years ago

Out-of-order timestamps in H.264 NAL jitter adjustment

Categories

(Core :: WebRTC: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 985254
feature-b2g 2.0

People

(Reporter: ekr, Unassigned)

References

Details

Attachments

(1 file)

Bug 1002402 applied jitter to SPS and PPS packets in order to avoid them being subject to duplicate suppression. Unfortunately, the way that the jitter is applied results in the PPS packets (which are sent second) having a timestamp prior to the SPS packets. The following patch probably isn't quite what we want but should get the timestamps in the right order.
Blocks: 911046
Comment on attachment 8416844 [details] [diff] [review]
0001-Fix-for-nal-timestamp-adjustment.patch

Review of attachment 8416844 [details] [diff] [review]:
-----------------------------------------------------------------

An improvement until we can solve the underlying bug via the packetization work (tested and fixes initial green-screen and reduces total delay until we see video)
Attachment #8416844 - Flags: review+
I'll note that SPS and PPS can come in any order in theory (IIRC)
In that case, we should probably instead modify the timestamps in the order
things appear in the packet.
feature-b2g: --- → 2.0
This is a bug in the original checkin, but will soon become moot with the patches for H.264 packetization in bug 985254
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985254
You need to log in before you can comment on or make changes to this bug.