No sound when placing one call on Nexus S

RESOLVED FIXED in 2.0 S1 (9may)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gerard-majax, Assigned: aknow)

Tracking

({regression})

unspecified
2.0 S1 (9may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p=2])

Attachments

(1 attachment, 1 obsolete attachment)

On Nexus S at least, reproducing with builds from yesterday. No sound when placing a call, no sound when playing music.

Audio channels do not seems to be correctly configured:
$ adb shell dumpsys media.audio_policy
PolicyManager Interface: 0x4774a0
Command Thread: 0x477348
Tones Thread: 0x477218
AudioCommandThread 0x477348 Dump
- Commands:
   Command Time        Wait pParam
  Last Command
   04      000162.328  1    0x47ad28
AudioCommandThread 0x477218 Dump
- Commands:
   Command Time        Wait pParam
  Last Command
   -1      000000.000  0    0x0

AudioPolicyManager Dump: 0x477530
 Hardware Output: 1
 A2DP Output: 0
 Duplicated Output: 0
 A2DP device address: 
 SCO device address: 
 Output devices: 00000003
 Input devices: 00040000
 Phone state: 2
 Ringer mode: 0
 Force use for communications 1
 Force use for media 0
 Force use for record 0
 Force use for dock 0

Outputs dump:
- Output 1 dump:
 Sampling rate: 44100
 Format: 1
 Channels: 00000003
 Latency: 92
 Flags 00000000
 Devices 00000002
 Stream volume refCount muteCount
 00     1.000     00       00
 01     0.000     00       00
 02     0.000     00       00
 03     0.000     00       00
 04     1.000     00       00
 05     0.000     00       00
 06     -1.000     00       00
 07     1.000     00       00
 08     0.004     00       00
 09     0.003     00       00

Inputs dump:

Streams dump:
 Stream  Index Min  Index Max  Index Cur  Can be muted
 00      00         05         05         1
 01      00         15         00         1
 02      00         15         00         1
 03      00         15         00         1
 04      00         15         15         1
 05      00         15         00         1
 06      00         15         08         1
 07      00         15         15         1
 08      00         15         01         1
 09      00         15         01         1

Total Effects CPU: 0.000000 MIPS, Total Effects memory: 0 KB
Registered effects:
Reporter

Comment 1

5 years ago
Looks like I was wrong: audio volumes are okay.
Reporter

Updated

5 years ago
Blocks: b2g-nexuss
Summary: No media sound, no call sound → No sound when placing call on Nexus S
Reporter

Comment 2

5 years ago
Keypad produces sound, but nothing when in call.
Reporter

Comment 3

5 years ago
There is sound when receiving calls.
Reporter

Comment 4

5 years ago
Strangely, it only happens when I have one call. If I place one call then open a second one, I get sound in both. Even after hanging up one of the calls.
Reporter

Updated

5 years ago
Summary: No sound when placing call on Nexus S → No sound when placing one call on Nexus S
Reporter

Comment 5

5 years ago
Placing a call to 111 (which does not exists) works, too, I get vocal feedback stating that this number do not exists.
Reporter

Comment 6

5 years ago
And it reproduces only with one specific SIM card (the same I've always used) in this device.
Reporter

Comment 7

5 years ago
Status:
 - OK with SFR and La Poste Mobile SIM cards
 - NOK with Orange F, Free Mobile and Bouygues Télécom SIM cards
Isn't this a dupe of bug 1002538? It sounds like the same problem.
Reporter

Comment 9

5 years ago
(In reply to Jason Smith [:jsmith] from comment #8)
> Isn't this a dupe of bug 1002538? It sounds like the same problem.

I'm not totally sure at all. This reproduces with some SIM but not all. I would not call it a dupe now.
See Also: → 1002538
Reporter

Comment 10

5 years ago
With a gecko at ad334fd83f8ce79eeb94d5e6102bbd4345d97f7a (git.mozilla.org), I don't reproduce the issue. I'm now testing with c6183f6ddf31c516e4e4489abd466e4b0cdf6bad, which includes bug 948498.

Myabe it's a migration/update issue rather than a plain bug in this code.
Reporter

Comment 11

5 years ago
It seems to be something within the range ad334fd83f8ce79eeb94d5e6102bbd4345d97f7a..540f98ccdd8c585b666f86d046f5b2d26dc63954
Flags: needinfo?(jsmith)
Reporter

Comment 12

5 years ago
Bisected:

3ff30a9083877e754290412b000c4bd760dfbfa8 is the first bad commit
commit 3ff30a9083877e754290412b000c4bd760dfbfa8
Author: Szu-Yu Chen [:aknow] <szchen@mozilla.com>
Date:   Fri Apr 25 14:59:40 2014 +0800

    Bug 999334 - Redesign pending outgoing call mechanism. r=hsinyi

:040000 040000 83fc3978566e01adaa6ce0e706f6f0c68fb3deaa d1ed7a83ad3eeab3e92081843d07a658d5db00eb M	dom
Depends on: 999334
Flags: needinfo?(szchen)
Flags: needinfo?(htsai)
Reporter

Comment 13

5 years ago
Locally reverting on mozillaorg/master fixes the issue for me:
$ git revert --no-commit ae6c78e6e8134aa74bdf7b697137bba8ee2116e9
$ git revert --no-commit 3ff30a9083877e754290412b000c4bd760dfbfa8
If that bug is the cause, then we should find out if this can happen on Tarako under the SIMs that this is known to happen on.
Flags: needinfo?(jsmith)
Hsinyi, 
Please help me double check the patch. Thx.
Attachment #8417159 - Flags: feedback?(htsai)
Flags: needinfo?(szchen)
Comment on attachment 8417159 [details] [diff] [review]
Ignore audio setting for place holder call

Review of attachment 8417159 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Let's give it a try!

In the meanwhile, we need to investigate more about the right timing and restriction to set phone_state_in_call. Also, why does this issue happen to a certain SIM? Because of timing?
Attachment #8417159 - Flags: feedback?(htsai) → feedback+
Flags: needinfo?(htsai)
In this patch
Bug 999334 - Redesign pending outgoing call mechanism. r=hsinyi

We set the audio channel a little bit earlier than before. Maybe it is the root cause that causes the problem. I have provided a patch here to postpone the channel setting.

Alexandre,
Could you help us apply the patch (attachment 8417159 [details] [diff] [review]) on the top of master and then verify whether it could resolve the problem? Thank you.
Assignee

Updated

5 years ago
Flags: needinfo?(lissyx+mozillians)
Reporter

Comment 18

5 years ago
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #16)
> Comment on attachment 8417159 [details] [diff] [review]
> Ignore audio setting for place holder call
> 
> Review of attachment 8417159 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good to me. Let's give it a try!
> 
> In the meanwhile, we need to investigate more about the right timing and
> restriction to set phone_state_in_call. Also, why does this issue happen to
> a certain SIM? Because of timing?

Excellent question. Meanwhile, I'm going to test this patch. Now that this comes up, I think it may have been a long standing issue: I remember, from time to time, hitting this. But I always blamed network :)
Flags: needinfo?(lissyx+mozillians)
Reporter

Comment 19

5 years ago
Comment on attachment 8417159 [details] [diff] [review]
Ignore audio setting for place holder call

It seems like it is fixing my issue. Thanks!
Attachment #8417159 - Flags: feedback+
I have try the same patch for bug 1002538 but it doesn't help.
(In reply to Alexandre LISSY :gerard-majax from comment #18)
> (In reply to Hsin-Yi Tsai  [:hsinyi] from comment #16)
> > Comment on attachment 8417159 [details] [diff] [review]
> > Ignore audio setting for place holder call
> > 
> > Review of attachment 8417159 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > Looks good to me. Let's give it a try!
> > 
> > In the meanwhile, we need to investigate more about the right timing and
> > restriction to set phone_state_in_call. Also, why does this issue happen to
> > a certain SIM? Because of timing?
> 
> Excellent question. Meanwhile, I'm going to test this patch. Now that this
> comes up, I think it may have been a long standing issue: I remember, from
> time to time, hitting this. But I always blamed network :)

Per discussion with Star, it should be fine to set phone_state_in_call before CLCC comes, or before REQUEST_DIAL responds. Hence, it's not obvious that bug 999334 is the root cause. I am concerned that there's a deeper cause that is still hidden. :( Please correct me if I misunderstand anything.

We might need to invite Audio peers to join the discussion. And maybe we should also check if phone_state has been set by other modules after Telephony set phone_state_in_call.
Correct comment 20!! I made something wrong when applying the patch.
The same patch could also resolve bug 1002538.
Per comment 21, even the patch here could resolve the issue but it may not be the correct solution for the root cause. We have found some weird behaviours when reproducing bug 1002538 (please see the update there).
(In reply to Szu-Yu Chen [:aknow] from comment #22)
> Correct comment 20!! I made something wrong when applying the patch.
> The same patch could also resolve bug 1002538.

Ok - I'll add that bug to block this one.

Do we know if this problem on Tarako?
Blocks: 1002538
See Also: 1002538
After some discussion with audio members, we suggest to land this patch first. Otherwise it might break the functionality of telephony for a long time. The patch is quite reasonable from telephony's perspective. Thus, it could be an official solution.

What we are worry about is that there might be a deeper problem which is not triggered before. So, we will file another bug to track it and investigate more deeply in the audio part. In that new bug, we could simply revert this patch and then reproduce all the weird behaviours.
Assignee

Updated

5 years ago
Attachment #8417159 - Flags: review?(htsai)
Comment on attachment 8417159 [details] [diff] [review]
Ignore audio setting for place holder call

Review of attachment 8417159 [details] [diff] [review]:
-----------------------------------------------------------------

Totally agree with comment 25. Please go file a bug, and let's move to the newly filed one for further investigation.
Attachment #8417159 - Flags: review?(htsai) → review+
Assignee

Updated

5 years ago
Assignee: nobody → szchen
Assignee

Updated

5 years ago
See Also: → 1006332
Rewrite the patch. Separate _updateCallAudioState() into two functions
 1. _updateActiveCall()
 2. _updateCallAudioState()
So _activeCall and aCall.isActive could be correctly updated and not ignored.
Attachment #8417159 - Attachment is obsolete: true
Attachment #8417925 - Flags: review?(htsai)
Assignee

Updated

5 years ago
Component: Gaia::System → RIL
Comment on attachment 8417925 [details] [diff] [review]
[final] Ignore audio setting for place holder call. r=hsinyi

Review of attachment 8417925 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.

::: dom/telephony/gonk/TelephonyProvider.js
@@ +271,5 @@
> +    if (aCall && aCall.callIndex === OUTGOING_PLACEHOLDER_CALL_INDEX) {
> +      return;
> +    }
> +
> +    let active = (this._activeCall !== null);

nit: I guess you define a new flag "active" because you want to have "active" and "incoming" be parallel. If so, the reason isn't strong for me but I think it's okay.
Attachment #8417925 - Flags: review?(htsai) → review+
Assignee

Updated

5 years ago
Attachment #8417925 - Attachment description: #2 Ignore audio setting for place holder call → [final] Ignore audio setting for place holder call. r=hsinyi
Assignee

Updated

5 years ago
Whiteboard: [p=2]
Target Milestone: --- → 2.0 S1 (9may)
https://hg.mozilla.org/mozilla-central/rev/5893e38d5a52
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Reporter

Comment 32

5 years ago
Hey, I'm sorry guys, but I feel like this has regressed a bit recently on my Nexus S: placing the first call often lead to a completely silent call. I think it also happen when receiving the first call. Subsequent calls are okay.
Flags: needinfo?(szchen)
Flags: needinfo?(htsai)
(In reply to Alexandre LISSY :gerard-majax from comment #32)
> Hey, I'm sorry guys, but I feel like this has regressed a bit recently on my
> Nexus S: placing the first call often lead to a completely silent call. I
> think it also happen when receiving the first call. Subsequent calls are
> okay.

Hi Alexnadre,

Bug 1013745 removes what we have done in this bug. Could you please try the latest build and see if the issue exists? If yes, please file another bug and kindly offer the log messages we always need. Thanks!
Flags: needinfo?(htsai)
Hi Alexandre,

As I remembered, the original issue only happens on the outgoing call. There is no problem for the incoming call. So if you still got the problem with the latest code, that might be a different issue.
Flags: needinfo?(szchen)
Reporter

Comment 35

5 years ago
(In reply to Hsin-Yi Tsai (OOO 5/30 ~ 6/8) [:hsinyi] from comment #33)
> (In reply to Alexandre LISSY :gerard-majax from comment #32)
> > Hey, I'm sorry guys, but I feel like this has regressed a bit recently on my
> > Nexus S: placing the first call often lead to a completely silent call. I
> > think it also happen when receiving the first call. Subsequent calls are
> > okay.
> 
> Hi Alexnadre,
> 
> Bug 1013745 removes what we have done in this bug. Could you please try the
> latest build and see if the issue exists? If yes, please file another bug
> and kindly offer the log messages we always need. Thanks!

This is already on a build with bug 1013745 applied.
You need to log in before you can comment on or make changes to this bug.