Closed Bug 1005546 Opened 6 years ago Closed 5 years ago

No keyboard ways to close the NetworkPanel (Inspect Network Request)

Categories

(DevTools :: Console, defect)

29 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 810265

People

(Reporter: casey.bessette, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 Iceweasel/29.0 (Beta/Release)
Build ID: 20140429183202

Steps to reproduce:

1. Open the developer web console (ctrl-shift-k)
2. Make sure the Console tab in the developer tools is selected with Net requests displaying
3. Load a page, and watch the Net requests populate the console
4. Click a Net request to open the http request detail popup showing request and response headers
5. Make sure focus is on the detail pop-up
6. Hit ctrl-w


Actual results:

The tab is closed.


Expected results:

The developer tools http request detail pop-up window should have closed.  For users of tiling window managers in Linux (e.g., the Awesome window manager, among others), there is no way to close the window without closing the tab because there are no window decorations or buttons available (e.g., there is no X close button).
Component: Untriaged → Developer Tools: Console
Hitting ctrl-shift-k again to close the developer tools will close the detail window, as well as the developer tools, which is better than closing the tab -- but it would be better if ctrl-w worked as expected.
I don't think the Ctrl-W should close this popup window, it is not a tab.
But indeed I did not find the any keyboard ways to close the NetworkPanel, so I do changed the summary.

It should can be Esc key to close, but it seem unable be focus?
Reproduce in Win8.1 Fx30.

ref:
http://hg.mozilla.org/mozilla-central/file/da7a2c70b407/browser/devtools/webconsole/network-panel.js
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/panel
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Ctrl-W closes tab instead of the web console pop-up request detail window → No keyboard ways to close the NetworkPanel (Inspect Network Request)
We plan to get rid of those panels, mainly due to how buggy the low-level implementation has proven to be.
Depends on: 861335
This is a duplicate of an older bug which I cant find now.
Whiteboard: dupeme
Thanks to msucan and I has found it.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810265
Whiteboard: dupeme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.