Closed Bug 1005562 Opened 6 years ago Closed 6 years ago

HomeProvider.addPeriodicSync() does not work

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: soeren.hentzschel, Unassigned)

References

(Blocks 1 open bug)

Details

I played a bit with the new customization possibilities of the Awesomescreen and created a small add-on based on https://github.com/leibovic/hub-boilerplate to show the latest news of my website on my home screen. For testing purposes I set HomeProvider.addPeriodicSync() to only 60 seconds (because I don't want to wait a full hour to test the add-on), but the list does not refresh after 60 seconds. The pull-to-refresh functionality works, so I don't think the data source is the problem, but the periodic sync. Tested with the latest Nighty
Blocks: lists
This is working as intended, we should update the document to make it clear that we limit you to syncing once per hour.

Were you seeing this message in the log?
http://mxr.mozilla.org/mozilla-central/source/mobile/android/modules/HomeProvider.jsm#169
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi,

yes, I can see the message in the console. Thank you.
Closing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
(In reply to Sören Hentzschel from comment #2)
> Hi,
> 
> yes, I can see the message in the console. Thank you.

Thanks so much for reporting a bug, though! Let us know if you run into anything else that doesn't seem quite right with these new APIs :)
You need to log in before you can comment on or make changes to this bug.