Closed Bug 1005593 Opened 6 years ago Closed 6 years ago

dispatched keypress events do not work on input=number fields

Categories

(Core :: DOM: Core & HTML, defect)

29 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: angelo.borsotti, Assigned: Agi)

References

Details

Attachments

(2 files)

Attached file errinput.html
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

open the attached page, activate firebug, click on "click here": the message
NS_ERROR_FAILURE: is displayed, and the event is not dispatched.
Note: if the field is declared as input=text, the event is dispatched.


Actual results:

I tried to dispatch an event to an input=number field from within a javascript
script


Expected results:

the event should have been dispatched
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: Core & HTML
Ever confirmed: true
Keywords: testcase-wanted
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86 → All
See Also: → 1003741
It looks like my patch for 1003741 fixes also this :)
(I'm not sure whether I should close this as duplicate, since it looks like a separate issue)
Assignee: nobody → agi.novanta
I'll post a mochitest soon.
It looks like the actual bug is a duplicate of Bug 1003741, because dispatching keypress events is already tested in /forms/test_input_number_key_events.html and were working already before the patch of 1003741. 

However, it seems to me that keypress event for numbers are not directly tested. I added a little mochitest in that file in case we want to test this as well. Thanks!
Attachment #8419110 - Flags: review?(ehsan)
Attachment #8419110 - Flags: review?(ehsan) → review+
Try'd mochitest-1,2 here: https://tbpl.mozilla.org/?tree=Try&rev=7a646ebf580b

Thank you!
https://hg.mozilla.org/mozilla-central/rev/135afc151b75
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.