mail reader too liberal identifying email links

VERIFIED DUPLICATE of bug 79064

Status

--
trivial
VERIFIED DUPLICATE of bug 79064
17 years ago
14 years ago

People

(Reporter: pete, Assigned: sspitzer)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4+) Gecko/20010917
BuildID:    2001091703

the mail reader seems to mistake anything with an at-sign (@) inside quotation
marks (") as an email address. for example, i was reading some mail with a small
inline XPM image. the following lines were drawn "blue and underlined" and were
clickable as mailto: links.

".+@#$%.                  .%$#@+.",
"++@#$%.                  .%$#@++",
"@@@#$%.                  .%$#@@@",
"@@@#$%.                  .%$#@@@",
"++@#$%.                  .%$#@++",
".+@#$%.                  .%$#@+."};

obviously it would be hard to catch _all_ strings like this that aren't real
email addresses. perhaps if there is more than one @ in the string, it is not
tagged as a link? or perhaps if there are no alphanumeric characters?




Reproducible: Always
Steps to Reproduce:
1. view mail with the example strings.


Actual Results:  see the text highlighted as a clicable mailto: url

Expected Results:  display as regular text

this is likely not really a bug for the "Mail and News" team, but i couldn't
find a better category.

Comment 1

17 years ago
Dupe of 79064. I should get the permissions to mark dupes soon.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 79064 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.