Data connection constantly coming up and down

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: gerard-majax, Assigned: edgar)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(1 attachment)

Reproducing 100% on Nexus S: enabling data connection works but results in the connection to be constantly up and down.
Reporter

Comment 1

5 years ago
05-05 09:59:53.905   750   750 I Gecko   : -*- DataConnectionManager: 'ril.data.enabled' is now true
05-05 09:59:53.905   750   750 I Gecko   : -*- DataConnectionManager: Default id for data call: 0
05-05 09:59:53.905   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: connect data call.
05-05 09:59:53.905   750   750 I Gecko   : -*- DataConnectionHandler[0]: setupDataCallByType: default
05-05 09:59:53.905   750   750 I Gecko   : -*- DataConnectionHandler[0]: Registering callback: [object Object]
05-05 09:59:58.452   750   750 I Gecko   : -*- DataConnectionHandler[0]: We're roaming, but data roaming is disabled.
05-05 09:59:59.831   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: nothing to do.
05-05 10:00:17.487   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: disconnect data call.
05-05 10:00:17.487   750   750 I Gecko   : -*- DataConnectionHandler[0]: deactivateDataCallByType: default
05-05 10:00:17.530   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: connect data call.
05-05 10:00:17.530   750   750 I Gecko   : -*- DataConnectionHandler[0]: setupDataCallByType: default
05-05 10:00:19.476   750   750 I Gecko   : -*- DataConnectionHandler[0]: Nothing to do during connecting/disconnecting in progress.
05-05 10:00:21.234   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: connect data call.
05-05 10:00:21.234   750   750 I Gecko   : -*- DataConnectionHandler[0]: setupDataCallByType: default
05-05 10:00:24.128   750   750 I Gecko   : -*- DataConnectionHandler[0]: We're roaming, but data roaming is disabled.
05-05 10:00:25.569   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: nothing to do.
05-05 10:00:28.038   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: disconnect data call.
05-05 10:00:28.038   750   750 I Gecko   : -*- DataConnectionHandler[0]: deactivateDataCallByType: default
05-05 10:00:28.089   750   750 I Gecko   : -*- DataConnectionHandler[0]: Data call settings: connect data call.
05-05 10:00:28.089   750   750 I Gecko   : -*- DataConnectionHandler[0]: setupDataCallByType: default
Reporter

Updated

5 years ago
Can this be seen on other devices on trunk?
Keywords: qawanted
Reporter

Comment 3

5 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> Can this be seen on other devices on trunk?

I have no idea, unfortunately. I'm seeing this on my dogfooding device and reproductibility is not 100%.

For RIL people, I have no idea if it's related, but when I reproduce the issue, I think (not checked 100% yet) that I'm losing the status of the data connection on roaming setting (my operator is doing roaming where it does not yet have a network coverage).
Reporter

Comment 4

5 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> Can this be seen on other devices on trunk?

I may have reproduced this right now on Vivien's Flame, with a Free Mobile SIM card (same as me).

Vivien, if you can check whether this happens again, it would be helpful.
Flags: needinfo?(jsmith)
Flags: needinfo?(21)
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #2)
> > Can this be seen on other devices on trunk?
> 
> I may have reproduced this right now on Vivien's Flame, with a Free Mobile
> SIM card (same as me).
> 
> Vivien, if you can check whether this happens again, it would be helpful.

Now that I can make phone calls with the Flame I'm going to dogfood it asap. Be sure that I will comment if I can not use data connections or if it constantly comes up and down.
Flags: needinfo?(21)
Ok - let's get RIL logs for this. Can you clarify the reproducible STR here in the bug? I want to see if we can reproduce it.
Flags: needinfo?(jsmith)
Reporter

Comment 7

5 years ago
(In reply to Jason Smith [:jsmith] from comment #6)
> Ok - let's get RIL logs for this. Can you clarify the reproducible STR here
> in the bug? I want to see if we can reproduce it.

STRs:
 - Enable data
 - wait

At some point, the data connection drops very often (like every 10 secs).

I have sent gecko and radio logs to Hsin-Yi by mail, the only obvious thing I could find was a request to drop data call because of a setting change.
Flags: needinfo?(htsai)
I've checked the logs and I guess the reason is because network reports that it is roaming, so in updateDataConnection() [1] in updateNetworkInfo(), it will try to disconnect data call cause data roaming is not enabled. However, later in checkRoamingBetweenOperators() [2] in updateNetworkInfo(), the final conclusion is that it's NOT roaming, so after data is disconnected, it will try to connect again.

Can we provide a patch for you to test if it solves the issue?


[1] http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/RadioInterfaceLayer.js#2318
[2] http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/RadioInterfaceLayer.js#2333
Thanks for comment 8. Clearing NI :)
Flags: needinfo?(htsai)
Alexandre,

Could you help us test with the attached patch?

Thanks.
Flags: needinfo?(lissyx+mozillians)
Reporter

Comment 11

5 years ago
(In reply to Jessica Jong [:jjong] [:jessica] from comment #10)
> Created attachment 8418660 [details] [diff] [review]
> proposed patch, v1.
> 
> Alexandre,
> 
> Could you help us test with the attached patch?
> 
> Thanks.

Sure, I'll try it. For now, I haven't been able to retrigger this bug today (same build).
Flags: needinfo?(lissyx+mozillians)

Updated

5 years ago
blocking-b2g: --- → backlog
Reporter

Comment 12

5 years ago
Jessica, just to keep you posted, I haven't yet tried the proposed patch since I haven't been able to reproduce this issue.
(In reply to Alexandre LISSY :gerard-majax from comment #12)
> Jessica, just to keep you posted, I haven't yet tried the proposed patch
> since I haven't been able to reproduce this issue.

Thanks for the update. It's strange... it should be reproducible with any device with the same SIM card and network (and modem as well). Have you tried with the same SIM card?
Reporter

Comment 14

5 years ago
(In reply to Jessica Jong [:jjong] [:jessica] from comment #13)
> (In reply to Alexandre LISSY :gerard-majax from comment #12)
> > Jessica, just to keep you posted, I haven't yet tried the proposed patch
> > since I haven't been able to reproduce this issue.
> 
> Thanks for the update. It's strange... it should be reproducible with any
> device with the same SIM card and network (and modem as well). Have you
> tried with the same SIM card?

Yes, no SIM difference. And not reproductible since I reported this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
removing QAWanted tag as this issue has been resolved.
Keywords: qawanted
Assignee

Comment 16

5 years ago
I am going to separate mobileconnection related code from RadioInterfaceLayer to MobileConnectionGonkProvider in bug 843452. Will consider the case mentioned in comment #8. Thank you.
Assignee: nobody → echen
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.