Add "break on mutate" support in the inspector (breakpoint on DOM modification)

RESOLVED DUPLICATE of bug 1547692

Status

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1547692
5 years ago
13 days ago

People

(Reporter: pbro, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [difficulty=hard] )

Reporter

Description

5 years ago
With bug 1004678 fixed, we'll be able to add "break on mutation" options to the inspector's markup-view.
Bug 1004678 is about making this possible at debugger level, and this bug should be about 2 things:

- adding the necessary UI to the markup-view (firebug does this within the context menu that appears when right-clicking on a node, see https://dl.dropboxusercontent.com/u/714210/firebug-break-on-mutation.png),
- starting the debugger in the background when a "break on mutation" option is chosen, and switching to the debugger panel in the toolbox when the code is paused.
Reporter

Updated

5 years ago
Depends on: 1004678
Regarding the additional UI in the markup view, it would be nice if the element that had this state applied had some visual indication beyond a checked item in the context menu.  Maybe a small icon next to the item in the tree, or some kind of border to call out elements with the behavior active.
(In reply to Brian Grinstead [:bgrins] from comment #1)
> Regarding the additional UI in the markup view, it would be nice if the
> element that had this state applied had some visual indication beyond a
> checked item in the context menu.  Maybe a small icon next to the item in
> the tree, or some kind of border to call out elements with the behavior
> active.

Another idea for the UI would be to show a breakpoint icon next to the element in the markup view, same as the icon you see when clicking in a gutter on script in the debugger
Duplicate of this bug: 1149877
Whiteboard: [devedition-40]
(Enhancing summary because I couldn't find this bug earlier..)
Summary: Add "break on mutate" support in the inspector → Add "break on mutate" support in the inspector (breakpoint on DOM modification)
Assigning P1 priority for some devedition-40 bugs. 

Filter on '148DD49E-D162-440B-AE28-E22632FC20AC'
Priority: -- → P1
Reporter

Updated

4 years ago
Whiteboard: [devedition-40] → [devedition-40][difficulty=hard]
Whiteboard: [devedition-40][difficulty=hard] → [difficulty=hard]
Reporter

Comment 6

3 years ago
Filter on CLIMBING SHOES
Priority: P1 → P3

Updated

a year ago
Product: Firefox → DevTools
Reporter

Updated

8 months ago
Blocks: 1493094
Reporter

Updated

7 months ago
Severity: normal → enhancement

Work has been started and will be tracked in bug 1547692.

Status: NEW → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: dbg-dom-bps-m1
Reporter

Updated

13 days ago
No longer blocks: 1493094
You need to log in before you can comment on or make changes to this bug.