Closed Bug 1005855 Opened 6 years ago Closed 5 years ago

Arrows in Bookmarks Menu are flipped (RTL locale)

Categories

(Firefox :: Theme, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 34
Iteration:
34.3
Tracking Status
firefox34 --- verified

People

(Reporter: eldada333, Assigned: seleznev.ru)

References

()

Details

(Keywords: rtl)

Attachments

(4 files)

Attached image Bug Screenshot
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

* Click on the bookmarks icon in the toolbar.


Actual results:

The sub-menu arrows are flipped.


Expected results:

The arrows shouldn't have been flipped.
Attached image Screenshot (Linux)
I can reproduce this problem on Linux as well. 

Steps to reproduce:

0. Get a clean copy of Firefox with RTL UI.
1. Click the bookmarks menu.

Current result:
Arrow pointing inside (pointing to the text)

Expected result:
Arrows should point outside. This is probably a regression caused by Australis.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: rtl
OS: Windows 7 → All
Hardware: x86 → All
Is this still broken on trunk as well?
Component: Untriaged → Theme
Flags: needinfo?(tomer.moz.bugs)
See Also: → 998481
(In reply to :Gijs Kruitbosch from comment #2)
> Is this still broken on trunk as well?

On Aurora it reproduce as well. Not tested on nightly as it is a bit more difficult, because there is no localized or RTL builds on nightly.
Flags: needinfo?(tomer.moz.bugs)
Flags: firefox-backlog+
Attached patch PatchSplinter Review
I tested it on Linux with AR locale.

---

Bad commit: http://hg.mozilla.org/mozilla-central/rev/03e7402f6fd3

On MacOS it should works fine because we already have "transform: scaleX(-1);"
in "./toolkit/themes/osx/global/menu.css" [1]. However, I can't test it. :(

1: https://mxr.mozilla.org/mozilla-central/source/toolkit/themes/osx/global/menu.css#101
Assignee: nobody → seleznev.ru
Status: NEW → ASSIGNED
Attachment #8473887 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8473887 [details] [diff] [review]
Patch

Review of attachment 8473887 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks for the patch! (sorry for the review delay, I was on holiday)
Attachment #8473887 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/83e0106a94d4
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Iteration: --- → 34.3
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: andrei.vaida
Verified fixed on Nightly 34.0a1 (2014-08-28), using Windows 7 64-bit, Ubuntu 14.04 LTS 64-bit and Mac OS X 10.9.4 with the following locales: ar, fa, he and also with a rtl-forced en-US build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.