Closed Bug 1005924 Opened 6 years ago Closed 6 years ago

URL outline is not resized correctly after changing device orientation

Categories

(Firefox for Android :: Awesomescreen, defect)

32 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox29 --- unaffected
firefox30 --- unaffected
firefox31 --- verified
firefox32 + verified
fennec 31+ ---

People

(Reporter: u421692, Assigned: mcomella)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached video edit mode
Steps to reproduce:
1. Open firefox and have the device in portrait mode
2. Tap on URL bar
3. Exit edit mode
4. Change orientation of the device in landscape mode
5. Tap on URL bar

Actual result:
URL bar orange outline from portrait mode reminisce on screen(please see attached video)

Regression window:
Bad build: 2014-04-30
Good build: 2014-05-01
Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e19812f56952&tochange=b227a707080f
Probably Bug 1000149 was the cause of this regression
Looks like 1000149 caused this regression.
Blocks: 1000149
tracking-fennec: --- → ?
Flags: needinfo?(michael.l.comella)
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
Flags: needinfo?(michael.l.comella)
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> Looks like 1000149 caused this regression.

Definitely - I'm on it.
I could have made the urlEditLayout INVISIBLE on hide, or this, and I chose this to avoid drawing more Views on-screen but I honestly don't know what would be more performant.
Attachment #8418211 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 8418211 [details] [diff] [review]
Find url bar translation with cancel button.

Review of attachment 8418211 [details] [diff] [review]:
-----------------------------------------------------------------

That looks fine to me. Please add a comment explaining what this calculation is actually doing.
Attachment #8418211 - Flags: review?(lucasr.at.mozilla) → review+
Attachment #8418211 - Attachment is obsolete: true
Comment on attachment 8418867 [details] [diff] [review]
Find url bar translation with cancel button.

This must be uplifted after bug 1000149.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1000149

User impact if declined:
  If bug 1000149 is uplifted without this, the url bar will animate incorrectly the first time after a rotation.
 
Testing completed (on m-c, etc.):
  Local testing.
 
Risk to taking this patch (and alternatives if risky):
  Low - a small and well-understood change that can only affect the amount the url bar expands.

String or IDL/UUID changes made by this patch: None
Attachment #8418867 - Flags: approval-mozilla-aurora?
Michael, the bug is marked as unaffected for 31 and you request an uplift to aurora. The tracking flag is wrong?
Flags: needinfo?(michael.l.comella)
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> Michael, the bug is marked as unaffected for 31 and you request an uplift to
> aurora. The tracking flag is wrong?

The issue is caused by bug 1000149 (a simplification of the UX refresh in aurora) which I hope to uplift.
Flags: needinfo?(michael.l.comella)
https://hg.mozilla.org/mozilla-central/rev/c44b4207aa5f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Attachment #8418867 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Alcatel One Touch 8008D(Android 4.1.2), on Nightly 32.0a1(2014-05-08).
tracking-fennec: ? → 31+
Verified as fixed on Alcatel One Touch 8008D(Android 4.1.2), on Aurora 31.0a2(2014-05-09).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.