Closed Bug 1006084 Opened 6 years ago Closed 6 years ago

Some scrollable web page does not use tiling

Categories

(Core :: Graphics: Layers, defect)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
blocking-b2g 2.0+
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: sotaro, Assigned: cwiiis)

References

Details

(Keywords: regression, Whiteboard: [priority])

Attachments

(3 files, 1 obsolete file)

When I accessed the following site from b2g device, tiling is not used even when the page is scrollable. Once I put the browser app to background and foreground again, the page is drawn with tiling.

*site
- http://www.yahoo.co.jp/

*STR
-[1] start browser app
-[2] access http://www.yahoo.co.jp/

* confirmed device
 - master flame,master nexus-4, master nexus-5
blocking-b2g: --- → 2.0?
This is likely the problem I described in bug 988511 comment 3.

Matt suggested "Yeah, we should fix that. I think we'd need LayerManager::CreateThebesLayerWithHint to return some extra information that tells us if the hint value resulted in a different layer backing type being created. Then we can make CreateOrRecycleThebesLayer only recycle the old layer if the new hint, and previous one match."
Bug 988511 might be related to this bug.
QA Wanted to see if this reproduces on 1.4.
Keywords: qawanted
I have no build version or video to go off of, but I made a video of what currently happens on a 1.4 Flame on the same webpage: http://youtu.be/3Waraqi8rUA

There are white areas on the edges of the screen that do not load in time when scrolling quickly. These areas load faster if the Browser app is suspended then resumed.

Device: Flame 1.4
BuildID: 20140515000202
Gaia: 2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: v10F-3
Keywords: qawanted
QA Contact: lmauritson
We want to fix this in 2.0 time frame bug it is not the blocker. Move this one to backlog and fix it later. We will focus on bug 988511 for now.
blocking-b2g: 2.0? → backlog
Whiteboard: [priority]
It seems something has changed in master that means this is hit very frequently on the Flame for 2.0 - Including on Twitter, and the FirefoxOS home-page. I think we may want to reconsider it's blocking status.
Blocks: 1023457
Got a patch in the works, taking.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
This is a regression from 1.4, right?
blocking-b2g: backlog → 2.0?
Keywords: regression
(In reply to Milan Sreckovic [:milan] from comment #8)
> This is a regression from 1.4, right?

It's possible for the bug to manifest in <2.0, but I'm seeing it consistently in 2.0/2.1 where as I almost never see it in 1.4. So I guess it's a partial regression?
This stores the ThebesLayerCreationHint on the created ThebesLayer and adds a new function, ShouldRecreateThebesLayer to LayerManager that can be called with a layer and a new hint to see if a layer should be recreated. (this is then used and respected in FrameLayerBuilder::CreateOrRecycleThebesLayer)

This only changes the behaviour on B2G.

I've confirmed that this fixes bug 1023457.
Attachment #8438491 - Flags: review?(matt.woodrow)
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8438491 [details] [diff] [review]
Allow thebes layer recreation on creation hint change

Review of attachment 8438491 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/Layers.h
@@ +357,5 @@
>      NONE, SCROLLABLE
>    };
>  
> +  virtual bool ShouldRecreateThebesLayer(ThebesLayer* aLayer,
> +                                         ThebesLayerCreationHint aCreationHint)

Why not move this onto the layer and avoid needing the aLayer parameter? We could also avoid exposing GetCreationHint too.

I'd also prefer naming similar to 'IsOptimizedFor(ThebesLayerCreationHint)'.
Rename ShouldRecereateThebesLayer to IsOptimizedFor as suggested.

Didn't move it to the layer as it would require the logic be spread between several files, away from the application of said logic (which is inside the layer manager in CreateThebesLayerWithHint).
Attachment #8438491 - Attachment is obsolete: true
Attachment #8438491 - Flags: review?(matt.woodrow)
Attachment #8439961 - Flags: review?(matt.woodrow)
Attachment #8439961 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/e92103cfb789
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Duplicate of this bug: 1023457
Attached video verify_video.MP4
Hi Hubert,
Could you help with it, thanks.
This issue has been verified unsuccessfully on Flame v2.0 & v2.1
STR:
1. Launch Browser.
2. Go to "http://www.yahoo.co.jp".
3. Pinch to zoom in page.
4. Slide left/right the page.
**When slide to right, the right edge will flash.
Found time: 11:42
See attachment: verify_video.MP4 and logcat_Flame2.1.txt
Flame 2.1 reproducing rate: 3/5
Flame 2.0 reproducing rate: 1/5
Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141202.034707
FW-Date         Tue Dec  2 03:47:18 EST 2014
Bootloader      L1TC00011880

Flame 2.1 versions:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141202.034824
FW-Date         Tue Dec  2 03:48:34 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(hlu)
Attached file logcat of flame 2.1
Thanks, Sue! :)
NI?whsu to follow up.
Flags: needinfo?(hlu) → needinfo?(whsu)
(In reply to Sue from comment #17)
> Created attachment 8531442 [details]
> verify_video.MP4
> 
> Hi Hubert,
> Could you help with it, thanks.
> This issue has been verified unsuccessfully on Flame v2.0 & v2.1
> STR:
> 1. Launch Browser.
> 2. Go to "http://www.yahoo.co.jp".
> 3. Pinch to zoom in page.
> 4. Slide left/right the page.
> **When slide to right, the right edge will flash.


Hi, Sue,

I think that you were talking about different bug.
Could you please submit a new bug to trace the bug you found.
Many thanks.
Flags: needinfo?(whsu) → needinfo?(lulu.tian)
(In reply to William Hsu [:whsu] from comment #20)
> (In reply to Sue from comment #17)
> > Created attachment 8531442 [details]
> > verify_video.MP4
> > 
> > Hi Hubert,
> > Could you help with it, thanks.
> > This issue has been verified unsuccessfully on Flame v2.0 & v2.1
> > STR:
> > 1. Launch Browser.
> > 2. Go to "http://www.yahoo.co.jp".
> > 3. Pinch to zoom in page.
> > 4. Slide left/right the page.
> > **When slide to right, the right edge will flash.
> 
> 
> Hi, Sue,
> 
> I think that you were talking about different bug.
> Could you please submit a new bug to trace the bug you found.
> Many thanks.

Thanks, William.
I will open a new bug to trace it.
Flags: needinfo?(lulu.tian)
(In reply to Sue from comment #21)
> (In reply to William Hsu [:whsu] from comment #20)
> > (In reply to Sue from comment #17)
> > > Created attachment 8531442 [details]
> > > verify_video.MP4
> > > 
> > > Hi Hubert,
> > > Could you help with it, thanks.
> > > This issue has been verified unsuccessfully on Flame v2.0 & v2.1
> > > STR:
> > > 1. Launch Browser.
> > > 2. Go to "http://www.yahoo.co.jp".
> > > 3. Pinch to zoom in page.
> > > 4. Slide left/right the page.
> > > **When slide to right, the right edge will flash.
> > 
> > 
> > Hi, Sue,
> > 
> > I think that you were talking about different bug.
> > Could you please submit a new bug to trace the bug you found.
> > Many thanks.
> 
> Thanks, William.
> I will open a new bug to trace it.

Hello, Sue,

Have you filed a new bug?
Thanks.
Thanks.
Flags: needinfo?(lulu.tian)
(In reply to William Hsu [:whsu] from comment #22)
> Hello, Sue,
> 
> Have you filed a new bug?
> Thanks.
> Thanks.

Sorry to delay. Yes, I had filed a new bug. See Bug 1119707
Flags: needinfo?(lulu.tian) → needinfo?(whsu)
See Also: → 1119707
(In reply to Sue from comment #23)
> (In reply to William Hsu [:whsu] from comment #22)
> > Hello, Sue,
> > 
> > Have you filed a new bug?
> > Thanks.
> > Thanks.
> 
> Sorry to delay. Yes, I had filed a new bug. See Bug 1119707

Thanks Sue!
I saw the new bug.
Flags: needinfo?(whsu)
You need to log in before you can comment on or make changes to this bug.