Closed Bug 1006657 Opened 8 years ago Closed 8 years ago

[B2G][Connect A2] Tapping on a contact in the ConnectA2 app will not respond properly

Categories

(Core :: DOM: Core & HTML, defect)

28 Branch
ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: dharris, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory][sprd305567][partner-blocker])

Attachments

(2 files)

Attached file Logcat
Description:
Starting a chat by tapping on a contact in ConnectA2 takes multiple tries and sometimes requires the user to tap in rapid succession. 

Prerequisites: Have at least 1 person in your contacts, A SIM card, and Data on

Repro Steps:
1) Update a Tarako to BuildID: 20140505173556
2) Go to Marketplace app> Connect A2 Install > Homescreen > Open Connect A2
3) Agree to Terms and Conditions> Register a Nickname and Phone Number
4) Enter the code you have recieved from SMS (If Prompted)
5) Allow ConnectA2 to access your contacts list
6) Tap on one of the contacts

Actual:
The button is very unresponsive and takes multiple taps to start a chat

Expected:
The first tap on the button opens a page to chat with that contact

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140505173556
Gaia: 48372ff88c712468a77a6f14a97f9978ee56eade
Gecko: 78015cc18d1f
Version: 28.1
Firmware Version: sp6821

Keywords: Unresponsive, Slow

Repro frequency: 100%
See attached: Logcat, Firewatch, Video - http://youtu.be/m1MB983K2II
Since this is one of the featured apps, noming.
blocking-b2g: --- → 1.3T?
I was unable to reproduce this issue on Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140505024001
Gaia: 667539f1ed4becc45b182a5f1046221d3eeb9e7c
Gecko: bf3fe474bf50
Version: 28.0
Firmware Version: v1.2-device.cfg
This isn't an e.me issue. It seems like a touch events problem, so maybe DOM?
Component: Gaia::Everything.me → DOM
Product: Firefox OS → Core
Version: unspecified → 28 Branch
triage: 1.3T+ as this is an important 3rd party app for tarako
blocking-b2g: 1.3T? → 1.3T+
Whiteboard: [tarako-exploratory] → [tarako-exploratory][sprd305567][partner-blocker]
verify with today's daily build, it's fine
Gaia      de7f2cb97b548f6e882e9a5077577827f1bcc054
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/446f2970cf94
BuildID   20140520164000
Version   28.1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Hi Joe,

   Please wait.
   Here is our QA latest test result, the version is 5/15. Please keep this bug open until our QA have verified ConnectA2 on my side.
   And please check Connect A2 issue again.

We have retested Facebook/Youtube/ConnectA2 and some games in India on latest version(W14.20.4) with sp6821a_gonk4.0_user.pac.
The behavior is samiler as last version with  sp6821a_gonk4.0.pac.

The issues for ConnectA2:
1) 6821 crash automatically and back to menu interface while uploading profile photo fom gallery while using Connct A2 app.(Already Raised bug:- 305567)
2) 6821 responds very slow while opening camera while using Connect A2 app.(Already Raised bug:- 305567)

The issues for Youtube:
3) Sometimes 6821 crash automatically and back to menu interface while using Youtube app.(Already Raised bug:- 298584)
4) 6821 fail to have smooth scroll on videos list while using Youtube app.(Already Raised bug:- 298584)

The issues for Facebook:
7) 6821 crash automatically while using Facebook functionality.(Already Raised bug:- 313363)
8) 6821 crash on MTC and back to menu interface while using Facebook app (Already Raised bug:- 313364)
9) 6821 hanged for sometimes & slow processing while using Facebook app.(Already Raised bug:- 313365)
10) 6821 shows character overlap on screen while using Facebook app.(Already Raised bug:- 313367)
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WORKSFORME → ---
We have corresponding issues to track issues on 3rd-party apps. Close this one.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.