Closed Bug 1007818 Opened 8 years ago Closed 8 years ago

crash in jemalloc_crash | arena_malloc | malloc | moz_xmalloc | mozilla::dom::Event::ConstructorInit(mozilla::dom::EventTarget*, nsPresContext*, mozilla::WidgetEvent*)

Categories

(Core :: JavaScript Engine, defect)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- affected

People

(Reporter: rpribble, Unassigned)

Details

(Keywords: crash, reproducible, Whiteboard: [flame-1.4-exploratory])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c8b09d80-2640-49df-8afa-34a342140508.
=============================================================

Repro Steps:
1) Updated Flame to BuildID: 20140508000201
2) Install and launch the Notes+ app from Marketplace
3) Create a new note
4) Attach a photo by taking a new image with the camera
5) Observe crash

Actual:
Crash is seen when user attaches an image by taking a new photo with the camera.

Expected:
User is able to attach images to notes without crashing.

Environmental Variables:
Device: Flame v1.4 MOZ ril
BuildID: 20140508000201
Gaia: 4ce973ef0732b0d52cb043210db598aa176b2ce9
Gecko: 16ab7f6b18f8
Version: 30.0
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
Whiteboard: [flame-1.4-exploratory]
Rachel - Shouldn't the 1.4 status flag here be set to affected?

Also adding qawanted to check this against a 1.3 Flame build.
blocking-b2g: --- → backlog
Component: Gaia::Notes → JavaScript Engine
Flags: needinfo?(rpribble)
Product: Firefox OS → Core
Version: unspecified → 30 Branch
Yes, sorry about that. Thank you for bringing it to my attention. Corrected.
Flags: needinfo?(rpribble)
Please use the OEM flame build in order to check 10G-2
I'm unable to reproduce this crash on today's 1.4 + v10G-2 firmware. Repro rate: 0 out of 3 attempts.

I'm also unable to reproduce this crash on just the v10G-2 base image. Repro rate: 0 out of 3 attempts.

Had the original reporter try it and she can't repro it on just the v10G-2 base image either. I think it's safe to close the bug.
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.