Closed Bug 1007836 Opened 5 years ago Closed 5 years ago

Send 'tablet' flag with TelemetryPing info

Categories

(Toolkit :: Telemetry, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: mfinkle, Assigned: mfinkle)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We track whether the device is considered a tablet or phone. The UI is different so the UI telemetry is affected.

We set the flag here:
http://mxr.mozilla.org/mozilla-central/source/xpcom/base/nsSystemInfo.cpp#281
Attachment #8419594 - Flags: review?(rnewman)
Let's do it and uplift it.
Assignee: nobody → mark.finkle
Status: NEW → ASSIGNED
OS: Linux → Android
Hardware: x86_64 → All
Attachment #8419594 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/mozilla-central/rev/a39f836bb42d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Comment on attachment 8419594 [details] [diff] [review]
telemetry-tablet v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: We want to do before and after testing with telemetry
Testing completed (on m-c, etc.): Works fine on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8419594 - Flags: approval-mozilla-aurora?
Attachment #8419594 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.