Closed Bug 1007945 Opened 8 years ago Closed 6 years ago

Ford.com buttons don't display properly in Firefox Android due to webkit CSS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: adamopenweb, Unassigned, Mentored)

References

()

Details

(Whiteboard: [webkitcss][country-us][needscontact])

Attachments

(4 files)

On Ford.com in the "Build & Price" section there are buttons which don't display properly on Firefox for Android. Testing in Chrome on Android the buttons display correctly.

:: Steps To Reproduce

1. Open Firefox OS browser
2. Navigate to http://www.ford.com
3. Click on "Build & Price" direct link: http://mt.bp3.ford.com/#appsimHome
4. Select a vehicle and configure the cars options to the end of the wizard

:: Expected Result

All content should render the same as Chrome on Android.

:: Actual Result

You may see some issues as you configure the car, at the end the "Get Internet Price" button is washed out and so are the buttons in that sub menu.

:: Additional Information
Attached image Chrome-1.png
Attached image Chrome-2.png
Attached image Firefox-1.png
Attached image Firefox-2.png
Oops made a typo in the description: 1. Open Firefox OS browser
Should be: 1. Open Firefox Android browser
OS: Mac OS X → Android
Hardware: x86 → ARM
Whiteboard: [webkitcss][country-us][mentor=astevenson]
The problem is this -webkit-gradient without standards-compatible syntax:

ul.summary-actions li.focus span {
background-image: -webkit-gradient(linear,0 0,0 100%,from(#0271ba),to(#025d99));
color: #fff;
}

Should also fix this border-radius:

ul.summary-actions li span {
border: 1px solid #ccc;
padding: 14px 3px;
display: block;
-webkit-border-radius: 9px;
}
This gradient should be added:

    background-image: linear-gradient(to 100%, #0271ba 0%, #025d99 100%);
Whiteboard: [webkitcss][country-us][mentor=astevenson] → [webkitcss][country-us][mentor=astevenson][contactready]
Mentor: astevenson
Whiteboard: [webkitcss][country-us][mentor=astevenson][contactready] → [webkitcss][country-us][contactready]
Whiteboard: [webkitcss][country-us][contactready] → [webkitcss][country-us][needscontact]
This is fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.