Closed Bug 1008017 Opened 7 years ago Closed 6 years ago

[Flame] microphone does not function during the call

Categories

(Core :: WebRTC, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
tracking-b2g backlog

People

(Reporter: bajaj, Unassigned)

Details

(Whiteboard: [1.4-JB-bug-bash])

Attachments

(1 file)

STR :

* goto apprtc.appspot.com and initiate a call 
* Mic on the device does not function at all

This was tried on MozillaGuest Wifi network with 1.4 buildid : 20140508000201

I think this is a Vendcom issue as we were not able to reproduce the issue on Open C with the same build
Component: WebRTC → Vendcom
Product: Core → Firefox OS
Version: 30 Branch → unspecified
When this issue happen, 
Could you help to check the logcat and find this pattern:
E/TrackUtils( 2218): setParameter failed usecase = USECASE_PCM_RECORDING err = -38
It looks like this one Bug:1003749
Flags: needinfo?(bbajaj)
The root cause might be the same with bug 1003749.
QA Wanted to get a logcat.
Keywords: qawanted
Flame is shipped with v1.3. this is agree in the contract. 
for anything happened on v1.4, we need to make sure it's not FxOS related.
please investigate internally first

btw, I cannot reproduce it with my Flame on v10F-3 OEM + v1.4 gaia/gecko
Below are my test results:
1. wireless in different APs, microphone and audio don't work (this is as expected)
2. wireless in the same AP, microphone and audio work well
Component: Vendcom → WebRTC
Product: Firefox OS → Core
Per alfredo's investigation into bug 1003749, the problem may occur in 2nd or later uses.  In that bug, the problem has never been seen in the first call, and on IRC he implied it's easier to provoke in audio+video (though he did indicate it occurs in pure audio tests).  The problem occurs in simple tests of gUM audio (https://mozilla.github.com/webrtc-landing/gum_test.html)

If anyone who can reproduce this can get a logcat that would help.  Mike - how do we get V10F-3?  I think the phones I received came with V10E (if I read the info right - I haven't seen a definitive "look here" to find the info).
Flags: needinfo?(mlien)
(In reply to Randell Jesup [:jesup] from comment #5)
> Per alfredo's investigation into bug 1003749, the problem may occur in 2nd
> or later uses.  In that bug, the problem has never been seen in the first
> call, and on IRC he implied it's easier to provoke in audio+video (though he
> did indicate it occurs in pure audio tests).  The problem occurs in simple
> tests of gUM audio (https://mozilla.github.com/webrtc-landing/gum_test.html)
> 
> If anyone who can reproduce this can get a logcat that would help.  Mike -
> how do we get V10F-3?  I think the phones I received came with V10E (if I
> read the info right - I haven't seen a definitive "look here" to find the
> info).

you can get the latest base image here:
https://mozilla.box.com/s/ii8sm72iv5v0955b8f8m

we just get this version two days ago
Flags: needinfo?(mlien)
(In reply to Mike Lien[:mlien] from comment #4)
> btw, I cannot reproduce it with my Flame on v10F-3 OEM + v1.4 gaia/gecko
> Below are my test results:
> 1. wireless in different APs, microphone and audio don't work (this is as
> expected)
> 2. wireless in the same AP, microphone and audio work well

I don't understand what this testing means. You should be able to establish a P2P call across different wifi networks.

I'll wait for qawanted to come back with a logcat & whether this reproduces on the latest 1.3 Flame base image using "Audio" & "Video&Audio" on http://mozilla.github.io/webrtc-landing/gum_test.html.
blocking-b2g: --- → backlog
Flags: needinfo?(bbajaj)
Using the webpage http://mozilla.github.io/webrtc-landing/gum_test.html - I ran the 'Audio' and the 'Audio&Video' tests several times. Each time the webpage itself stated "success!". While I did not see the Logcat error in comment 1 I did see several errors fire when I would hit play/pause on the webpage; such as:

05-30 14:43:01.983: E/GeckoConsole(301): Content JS WARN at app://system.gaiamobile.org/shared/js/l10n.js:79 in consoleWarn: [l10n] #perm-audio-capture-more-info is undefined.


I am attaching the logcat

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: Unknown
Version: 28.0
Firmware Version: v10G-2
Keywords: qawanted
Attached file logcat.txt
Ok - I'm going to assume this is now resolved per the above comments on the latest image, so I'm closing this.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.