aol.com - Test for writing content to a pop-up 'on the fly' fails

RESOLVED FIXED in Future

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: jmkobayashi, Unassigned)

Tracking

unspecified
Future
x86
Windows 2000

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
1. navigate to the url 
http://browsertest.web.aol.com/tests/javascript/javascpt/testpgs/window/onthefly
.htm
2.As instructions state, fill in some text and hit "open pop up" 
3.Pop up appears with text 'undefined" 
4.Expected result: Pop up should contain text that user typed
Tested in .0.9.4 build. Discovered while running smoketests for embedding at: 
http://www.mozilla.org/quality/smoketests/embed-basic-test.html EM18

This works as stated using IE.

Comment 1

17 years ago
->DOM
Assignee: asa → jst
Component: Browser-General → DOM HTML
QA Contact: doronr → stummala
Summary: Test for writing content to a pop-up 'on the fly' fails → Test for writing content to a pop-up 'on the fly' fails

Comment 2

17 years ago
failed in 2001-10-30-03. It is possible to have many sites which write messages 
dynamically onto the pop up windows (say welcome user). Attaching a testcase
Target Milestone: --- → mozilla0.9.6

Comment 3

17 years ago
Created attachment 55847 [details]
testcase attached
Pushing to mozilla0.9.7
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 5

17 years ago
The problem is that the testcase does
<input name="content" type="text">

then in javascript:
content.value

expecting to get the value of the text input. however in mozilla |content| will
map to window.content (or is it replaceable?), and in any case an input element
is not accessible directly by its name attribute.

Evangelism?
Yup, evangelism. The testcase needs to do document.content to find the input...
Assignee: jst → doronr
Component: DOM HTML → US General
Product: Browser → Tech Evangelism
QA Contact: stummala → zach
Target Milestone: mozilla0.9.9 → ---
Version: other → unspecified

Updated

17 years ago
Blocks: 121236
Summary: Test for writing content to a pop-up 'on the fly' fails → aol.com - Test for writing content to a pop-up 'on the fly' fails

Updated

17 years ago
Keywords: evang500

Comment 8

17 years ago
contacting
Status: NEW → ASSIGNED

Comment 9

16 years ago
contacted again. mine.
Assignee: doron → bclary
Status: ASSIGNED → NEW

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Mar

Comment 10

15 years ago
ain't gonna happen
Assignee: bc → english-us
Status: ASSIGNED → NEW
QA Contact: zach → english-us
Target Milestone: Mar → Future

Comment 11

14 years ago
[bug248549notfixed]
URL is 404
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 13

10 years ago
FIXED by death of page, then, assuming the 404 page works fine.
Resolution: INVALID → FIXED
woohoo, thanks Chris for adding a comment, a few people still seem to be active in this area, I'm happy !
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.