If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The focus set by using the tab key is not persistant when using the back button.

VERIFIED DUPLICATE of bug 36539

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED DUPLICATE of bug 36539
16 years ago
16 years ago

People

(Reporter: Brian Vancil, Assigned: Brian Ryner (not reading))

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The tab key is useful for navigating lists of links rather than pointing and
clicking, but once the user has selected a link (by Enter, say), the tab
information is lost.  When the user hits back, the page is (usually) scrolled to
the location on the page as it was before following the new link, but the
highlighted focus box (as moved by the tab key).  The result is that pressing
the tab key cycles from the beginning of the document.  Not only is this
inconvenient, but it's also an accessibility problem: think minimal keystrokes
to do a job.  Thanks.

Comment 1

16 years ago
-> bryner, focus
Assignee: aaronl → bryner
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla1.0

Comment 2

16 years ago
There are probably issues with this feature when we start talking about cache 
validation and reloading the page or with dynamic content. In any case this is 
probably a large-ish feature and definitely needs some thought and discussion 
on the best way to implement it.

Incidentally, I'd love to know how IE does it...

Comment 3

16 years ago
dup of 36539

*** This bug has been marked as a duplicate of 36539 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.