Closed Bug 1008581 Opened 6 years ago Closed 6 years ago

New loading throbbers animation is slow, laggy and choppy

Categories

(Firefox :: Theme, defect)

32 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox32 + verified

People

(Reporter: Virtual, Assigned: phlsa)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, perf, regression, Whiteboard: [fixed by patch backout from bug #994954])

New loading throbbers animation is slow, laggy and choppy.
It don't look like steady 60 FPS or more.
It's especially visible on this blue throbber.
I have to confirm this. The blue throbber animation is sometimes really laggy.
I see that as well, especially on the blue throbber.
As the throbber animation loads, it appears, or feels like its delaying the loading of web pages.
the new Throbbers comsume a load of CPU & GPU usage
12-14% CPU @Intel Atom N450
throbbers consume 4-10% CPU @Intel i7
do you cache it or not, and could you guys convert it to SVG,
you can make them be hardware acceleration and reducing the CPU usage.
As the e10s is not enabled+stable yet,
so I guess reducing CPU usage while page loading is important for now.

I guess it should not show performance impact as it an animation.
but too bad, Firefox is not taking much time into the FPS(responsiveness)
like IE11 or Chrome dev tools, that can showing about responsiveness...


So far I am feeling a bit slow because the throbber is having a attractive color(might be also slowing rolling speed to hit 360°), it is stutter because of 30FPS, and more stutter because the Firefox is easy to hung while loading page, causing it drop to 15FPS
If you go back and look at the previous throbber and progress bar bugs, there was an issue of performance highlighted which is how we ended up with what we had previously, it would appear that these issues were overlooked for this newest implementation. I'd suggest that some tests are created to prevent such performance bog should anyone else feel the need to update the throbbers in the future.
Duplicate of this bug: 1008900
Fixed by backout of bug 994954.
Status: NEW → RESOLVED
Closed: 6 years ago
No longer depends on: 1008324
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Assignee: nobody → philipp
Whiteboard: [fixed by patch backout from bug #994954]
You need to log in before you can comment on or make changes to this bug.