Closed Bug 1008610 Opened 6 years ago Closed 6 years ago

White border around button

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox30 + verified
firefox31 + verified
firefox32 --- verified
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: evilpie, Assigned: mattwoodrow)

References

Details

(Keywords: regression, Whiteboard: [bugday-20140514])

Attachments

(2 files)

Attached image button.png
Latest Firefox Nightly on Linux Mint.
Got a regression range?
Flags: needinfo?(evilpies)
Keywords: regression
Last good revision: 2a03b34c8953 (2014-05-08)
First bad revision: cf89b5d018f8 (2014-05-09)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2a03b34c8953&tochange=cf89b5d018f8

I tried bisecting revisions with mozregression, but that doesn't seem to work.
Flags: needinfo?(evilpies)
This affects the "allow" button for extension installation and firebug2s toolbar button too

Last good revision: 5bbc85136202
First bad revision: d1155f994a3a
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5bbc85136202&tochange=d1155f994a3a
These regression ranges overlap, but one isn't a subset of the other.

That's very confusing. :-(
Flags: needinfo?(gijskruitbosch+bugs)
Just to be clear mozregression marks those as a subset from inside of 08/05 - 09/05. I don't have a tree at work so can't do a build test until i get home.
(In reply to Cork from comment #5)
> Just to be clear mozregression marks those as a subset from inside of 08/05
> - 09/05. I don't have a tree at work so can't do a build test until i get
> home.

Huh, interesting. d1155f994a3a is in the range, but 5bbc85136202 is not. I guess it's because of merging, so I suspect (but am not 100% sure) that the real range is the intersection of the two, which is quite small:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8a5a9a06f59a&tochange=d1155f994a3a
Maybe this has something to do with Bug 1003707? I could imagine if for some reason we calculate a little bit to large element size and thus end up with a white background.
The first bad revision is:
changeset:   182069:3b5fb4abaa3f
user:        Matt Woodrow <mwoodrow@mozilla.com>
date:        Thu May 08 11:23:44 2014 +1200
summary:     Bug 1003707 - Pass surfaces sizes in to CreateSourceSurfaceFromNativeSurface instead of trying to extract it from cairo. r=Bas
Blocks: 1003707
Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(matt.woodrow)
Why bug 1003707 was landed on m-c and m-a at all? Firefox 31+ had no problem.
Assignee: nobody → matt.woodrow
Attachment #8421441 - Flags: review?(bas)
Flags: needinfo?(matt.woodrow)
We should track this since we're uplifting bug 1003707.
Attachment #8421441 - Flags: review?(bas) → review+
https://hg.mozilla.org/mozilla-central/rev/b22b1b69249b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Please nominate for uplift
Flags: needinfo?(matt.woodrow)
Comment on attachment 8421441 [details] [diff] [review]
Fix copy-paste error

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1003707
User impact if declined: Broken native theme rendering on linux
Testing completed (on m-c, etc.): Been on m-c, manually tested
Risk to taking this patch (and alternatives if risky): Very low risk, just fixes a typo.
String or IDL/UUID changes made by this patch: None.
Attachment #8421441 - Flags: approval-mozilla-beta?
Attachment #8421441 - Flags: approval-mozilla-aurora?
Flags: needinfo?(matt.woodrow)
Attachment #8421441 - Flags: approval-mozilla-beta?
Attachment #8421441 - Flags: approval-mozilla-beta+
Attachment #8421441 - Flags: approval-mozilla-aurora?
Attachment #8421441 - Flags: approval-mozilla-aurora+
Hi, 

I was able to reproduce it on Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140510030204 CSet: 7586c29906b5

I can confirm that the issue is no longer present in the latest Nightly Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140514030203 CSet: 2f8af55d6e9a

Cheers,
Francesca
Whiteboard: [bugday-20140514]
And now verified on latest Aurora and latest Beta as well.

Cheers,
Francesca
Status: RESOLVED → VERIFIED
Component: General → Graphics
Product: Firefox → Core
Target Milestone: Firefox 32 → ---
You need to log in before you can comment on or make changes to this bug.