Closed Bug 1008645 Opened 6 years ago Closed 6 years ago

Add UI telemetry for First-run

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox31 --- verified
firefox32 --- verified

People

(Reporter: mfinkle, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This patch adds a "firstrun" Session by using some existing checks in GeckoProfile. We only want "firstrun" for the very first-run and not for any new profile, or even for Guest Browsing (which is also a new profile).

The patch uses the presence of a fully created profiles.ini file to act as the check. There might be other ways, but this seems to work. If there is a better way, please let me know.

If the user chooses to "Clear Data" using the Android "App" settings, we will have a "firstrun" again.
Attachment #8420610 - Flags: review?(bnicholson)
Attachment #8420610 - Attachment is patch: true
Comment on attachment 8420610 [details] [diff] [review]
uitelemetry-firstrun v0.1

Review of attachment 8420610 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, this should be useful data.
Attachment #8420610 - Flags: review?(bnicholson) → review+
https://hg.mozilla.org/mozilla-central/rev/c2c0ff81cb72
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8420610 [details] [diff] [review]
uitelemetry-firstrun v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: We want to do before and after testing with telemetry
Testing completed (on m-c, etc.): Works on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8420610 - Flags: approval-mozilla-aurora?
Attachment #8420610 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in builds:
32.0a1 (2014-05-27);
31.0a2 (2014-05-27);

Device: Samsung Galaxy Nexus (Android 4.2.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.