Unable to defer a new account to the Global Inbox

RESOLVED FIXED in seamonkey2.29

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

({regression})

unspecified
seamonkey2.29
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.26 fixed, seamonkey2.27 fixed, seamonkey2.28 fixed, seamonkey2.29 fixed)

Details

Attachments

(2 attachments)

Creating a POP3 account deferred to the Global Inbox does not work. The error "Could not get IID for pop3: TypeError: srcServer.protocolInfo is undefined" on line 451 of AccountWizard.js was logged on the console during account creation.
This is a regression from bug 861767. We try to get the protocol info for a server but the source server is only a JS object, not an actual server object. Getting the protocol info for the destination server should work though.
Blocks: 861767
I remember seeing this and fixing this somewhere...
Yes, https://bug953339.bugzilla.mozilla.org/attachment.cgi?id=8379873 .

Should we use the same fix in the AccountWizard.js?
The "Leave mail on server" checkbox is also affected.
This has some extra cleanup which may or may not make sense, since there is more code in the try block.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8420856 - Flags: review?(iann_bugzilla)
Sorry, I didn't see your email, I was busy testing my fix.

(In reply to aceman from comment #3)
> Yes, attachment 8379873 [details] [diff] [review].
> 
> Should we use the same fix in the AccountWizard.js?

Porting the aw-incoming.js part of that attachment would also work. It just so happens that we do have a real server available in this case.
Attachment #8420856 - Flags: review?(iann_bugzilla) → review+
> -        IID = srcServer.protocolInfo.serverIID;
> +        IID = destServer.protocolInfo.serverIID;
>        } catch (ex) {
>          Components.utils.reportError("Could not get IID for " + srcServer.type + ": " + ex);

Shouldn't this be:
         Components.utils.reportError("Could not get IID for " + destServer.type + ": " + ex);
(In reply to Philip Chee from comment #8)
> > -        IID = srcServer.protocolInfo.serverIID;
> > +        IID = destServer.protocolInfo.serverIID;
> >        } catch (ex) {
> >          Components.utils.reportError("Could not get IID for " + srcServer.type + ": " + ex);
> 
> Shouldn't this be:
>          Components.utils.reportError("Could not get IID for " +
> destServer.type + ": " + ex);

They have the same type (which is why they have the same protocol info).
Pushed comm-central changeset 68dbbff90bd5.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.29
Comment on attachment 8420856 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 861767
User impact if declined: Some SeaMonkey account wizard options are ignored
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None
Attachment #8420856 - Flags: approval-comm-beta?
Attachment #8420856 - Flags: approval-comm-aurora?
Comment on attachment 8420856 [details] [diff] [review]
Proposed patch

a=me
Attachment #8420856 - Flags: approval-comm-beta?
Attachment #8420856 - Flags: approval-comm-beta+
Attachment #8420856 - Flags: approval-comm-aurora?
Attachment #8420856 - Flags: approval-comm-aurora+
Blocks: 1018792
Landing to comm-release in prep of SeaMonkey 2.26.1

$ hg tip
changeset:   20189:2e990ad00dac
branch:      SEA_2_26_1_RELBRANCH
tag:         tip
user:        Neil Rashbrook <neil@parkwaycc.co.uk>
date:        Mon Jun 02 00:30:40 2014 +0100
summary:     Bug 1008835 Unable to defer a new account to the Global Inbox r=IanN a=IanN
You need to log in before you can comment on or make changes to this bug.