forms not posting data properly

VERIFIED DUPLICATE of bug 57720

Status

()

--
major
VERIFIED DUPLICATE of bug 57720
17 years ago
17 years ago

People

(Reporter: bugzilla.mozilla.org, Assigned: rods)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001091303

I can't login in to mail.yahoo.com, secure or standard, bugzilla.mozilla.org or 
any other site involving a form post.  

In the case of "http://mail.yahoo.com", the data appears to be sent to the 
server, but the page just is returned as if no data was posted.  It does *not* 
return a message saying invalid password.

In the case of "http://bugzilla.mozilla.org/query.cgi?GoAheadAndLogIn=1", I 
recieved an error message after entering my email address and password and 
hitting the login button stating me email address was improperly formatted, but 
the error message itself contains my properly formatted email address.






Reproducible: Always
Steps to Reproduce:
1. go to http://bugzilla.mozilla.org/query.cgi?GoAheadAndLogIn=1
2. enter email address and password and hit login


Actual Results:  i received the following error message:

****************************************
The e-mail address you entered (jiggity-mo@kinobe.com) didn't match our minimal 
syntax checking for a legal email address. A legal address must contain exactly 
one '@', and at least one '.' after the @, and may not contain any commas or 
spaces. It must also not contain any of these special characters: \ ( ) & < 
> , ; : " [ ] or any whitespace.
****************************************

notice, it appears it is getting the form data, but something else is making it 
barf.

Expected Results:  successful login

i am using win2k professional, service pack 2, build 2195, on an ibm thinkpad 
600x.

Comment 1

17 years ago
I believe that build had a problem with storing cookies (used by both bugzilla
and yahoo! mail). I know it's been fixed, so try a more recent build.

Comment 2

17 years ago
Does not occur on 2001091311 OS 9, which is exactly the same build as you, if
I'm not gravely mistaken. Strange.
Marking WFM 2001100803 on Win2k. 

Reporter: Please try a more recent build and reopen this bug if it still occurs
for you.
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before installing the
new one)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
I am still having problems related to this bug.  I have deleted my Mozilla 
folder, installed version 0.9.5.  I was not able to log in to mail.yahoo.com.  
After selecting Edit->Preferences->Privacy & Security->Cookies, "Enable All 
Cookies", View Stored Cookies, Remove All Cookies and re-trying, I was able to 
login.  However, when I attempt to send a mail, I am told to re-login b/c my 
login session has expired, even though I logged in seconds ago.  Seems I still 
have a cookie problem.  

This may be a problem from an old install.  Under Add/Remove programs, in 
addition to "Mozilla (0.9.5)", I also have two previous copies of 
Mozilla: "Mozilla Seamonkey (5.0a1)" and "Mozilla Seamonkey 5.0a1" [note: 
latter entry is only different in containing parens].  When I select 
Change/Remove, I receive the following Error Alert:

***************************************************
0 : Uninstall log folder not found: 

HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\5.0a1 (en)\Uninstall\Uninstall 
Log Folder
***************************************************

I even went as far as attempting to create the folder structure in my registry 
to duplicate the above (starting from 5.0a1...) but the uninstall still aborted 
in the same fashion.  

What next?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

17 years ago
This may or may not be helpful: I've noticed that often when POSTing a form with
caching set on "automatic", the previously cached result of doing the POST is
returned, even if the values in the form have changed.  Maybe that's what you're
seeing?  Changing the cache setting to "every time" works around the trouble.
(Reporter)

Comment 6

17 years ago
"Every time I view the page" was already selected.  The problem persists.
1)  Are you using a proxy?

2)  What is the default character coding set to in 

Edit > Preferences > Navigator Languages ?
(Reporter)

Comment 8

17 years ago
thank you boris!  turns out that my defaut character codings was....  Armenian
(ARMSCII-8).  dunno how that happened.  however, when i changed the default
coding to Western (ISO-8559-1) and restarted mozilla, i was finally able to
login and reply to messages.  in fact, i'm using mozilla to log this bug report,
which i've never been able to do.  wahoo!

i decided not to close this in case some one wanted to follow up and make sure
all mozilla instances defaulted to an appropriate character coding.  thanks for
everyone's help and attention.  go mozilla!
There was a preferences bug a while back that corrupted profiles to have the 
Armenian character coding....

Now that you've switched the coding over, it should not switch back again.

Duplicate of "Armenian character encoding picked if language dropdown doesn't 
completely populate [and thus can't login to bugzilla] [form submission encoding 
wrong]"

*** This bug has been marked as a duplicate of 57720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.