Closed Bug 1009409 Opened 6 years ago Closed 6 years ago

[Buri][V2.0] The unlock toggle is not located at bottom of lock screen

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: whsu, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [FT:System-Platform])

Attachments

(1 file)

Attached image 2014-05-13-14-39-48.png
* Description:
  This is a regression bug and can be reproduce on Buri device with V2.0 build.
  After you lock the homescreen, the unlock toggle is not located at bottom of lock screen
  Attach the screenshot. (2014-05-13-14-39-48.png)

* Reproduction steps:
  1. Enable lock screen
  2. Press power on button to turn off  screen
  3. Press power on button again
  4. Check location of unlock toggle

* Expected result:
  Unlock toggle is located at bottom of lock screen

* Actual result:
  Unlock toggle is not located at bottom of lock screen

* Reproduction build:(Buri - Firefox OS V2.0 inside)
 - Gaia      2f89c43e798ccba631025bedc47a1fb24e830cf2
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/4b6d63b05a0a
 - BuildID   20140512160204
 - Version   32.0a1
Whiteboard: [FT:System-Platform]
Lockscreen works as normal on following build
*Build information: (V2.0)
 - Gaia      c1a8cbaac1d921cfb50e3a2600720b75cf5afabd
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/6f5597d4d3e3
 - BuildID   20140512040203
 - Version   32.0a1

But, the bug is injected on 5/12
*Build information: (V2.0)
 - Gaia      2f89c43e798ccba631025bedc47a1fb24e830cf2
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/4b6d63b05a0a
 - BuildID   20140512160204
 - Version   32.0a1

Thanks!
Thanks a lot. I would survey this ASAP.
Maybe. I would do a bisect to confirm it.
After bisect, this is caused by the patch of Bug 1003870,
commit: 33bab4b3e8af2559fa5f68c19fbaf13e40c64928

Git bisect output:

Author: Alive Kuo <alegnadise@gmail.com>
Date:   Thu May 8 14:07:20 2014 +0800

    Bug 1003870 - Resize anyway if app is opened

:040000 040000 22909a7edbf3862ea843c3b61213e2ce8fd62219 2444b8051e5b31797d01b0afabf4caad46b58b3f M	apps
Flags: needinfo?(alive)
Closing as fixed by backout.
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: regression
Resolution: --- → FIXED
will fix this in 1003870.
Flags: needinfo?(alive)
Component: Gaia::Homescreen → Gaia::System::Lockscreen
Duplicate of this bug: 1010139
Duplicate of this bug: 1009698
Duplicate of this bug: 1010455
Tested and working
Hamachi
1.5
Gecko: d6d67da
Gaia:9078b76
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.