Closed Bug 1009451 Opened 6 years ago Closed 6 years ago

TypeError: tabs[i]._preview is undefined

Categories

(SeaMonkey :: OS Integration, defect)

x86_64
Windows 7
defect
Not set

Tracking

(seamonkey2.26 wontfix, seamonkey2.27 wontfix, seamonkey2.28 fixed, seamonkey2.29 fixed)

RESOLVED FIXED
seamonkey2.30
Tracking Status
seamonkey2.26 --- wontfix
seamonkey2.27 --- wontfix
seamonkey2.28 --- fixed
seamonkey2.29 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(2 files)

When you have exactly 21 tabs and you close a tab, the AeroPeek object turns itself on. However it tries to turn itself on for the tab you've just closed, which doesn't work, because we've already deleted the preview. This leaves AeroPeek in an inconsistent state.
Attached patch Possible patchSplinter Review
After removing the controller we check the preview count, and if the count drops to exactly 20 we enable AeroPeek, which tries to enable for the tab we're just deleting. The problem arises because we remove the controller after deleting the preview. If we remove the controller first, we will temporarily enable the preview, then re-disable it, and then the tab ordering gets updated.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8421589 - Flags: review?(bugzilla)
This version simply skips tabs that have no preview, presuming that they're being deleted.
Comment on attachment 8421589 [details] [diff] [review]
Possible patch

I like this one better, both work fine though :)
Attachment #8421589 - Flags: review?(bugzilla) → review+
Pushed comm-central changeset 73c3ff8185e7.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.30
Comment on attachment 8421589 [details] [diff] [review]
Possible patch

[Approval Request Comment]
Regression caused by (bug #): 839891
User impact if declined: Aero Peek errors if you close the 21st tab
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #8421589 - Flags: approval-comm-beta?
Attachment #8421589 - Flags: approval-comm-aurora?
Comment on attachment 8421589 [details] [diff] [review]
Possible patch

a=me
Attachment #8421589 - Flags: approval-comm-beta?
Attachment #8421589 - Flags: approval-comm-beta+
Attachment #8421589 - Flags: approval-comm-aurora?
Attachment #8421589 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.