Closed Bug 1009621 Opened 5 years ago Closed 5 years ago

[B2G][Gallery][Tarako] Switching from the Camera to Gallery app will partially show the Camera app while in Gallery

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified)

RESOLVED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified

People

(Reporter: jschmitt, Assigned: alive)

References

()

Details

(Keywords: regression, Whiteboard: [sprd313265][partner-blocker])

Attachments

(2 files)

Attached file log.txt
Description:
Opening the Gallery app, then selecting the Camera icon, then selecting the Gallery app will show the Camera and Gallery at the same time.

Repro Steps:
1) Update a Buri to BuildID: 20140513014002
2) Open the Gallery app
3) Select the 'Camera' icon to switch to the Camera app
4) Select the 'Grid' icon to open the Gallery app

Actual:
The Gallery app opens with the Camera app partially showing

Expected:
The Gallery app opens without any issues.

1.3 Environmental Variables:
Device: Buri 1.3
BuildID: 20140513014002
Gaia: 53e2fcfe410c50a4a6ee38d27e8a8590d8460e00
Gecko: 32e10ec2cf9b
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac

Notes:
Repro frequency: 100%
See attached: https://www.youtube.com/watch?v=aNCXJJ22mzE
Adding qawanted to test on Buri.
Keywords: qawanted
Correction to comment 0, these are the correct environmental variables.

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140513014002
Gaia: 53e2fcfe410c50a4a6ee38d27e8a8590d8460e00
Gecko: 32e10ec2cf9b
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does not occur on the buri 1.3 MOZ 

1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140508024005
Gaia: 0d02564946814acfdab13f0b9867d140d318b8ac
Gecko: a7252ab569c4
Version: 28.0
Firmware Version: V1.2-device.cfg
Keywords: qawanted
Summary: [B2G][Gallery] Switching from the Camera to Gallery app will partially show the Camera app while in Gallery → [B2G][Gallery][Tarako] Switching from the Camera to Gallery app will partially show the Camera app while in Gallery
QA Contact: jzimbrick
blocking-b2g: --- → 1.3?
blocking-b2g: 1.3? → 1.3T?
Tarako 1.3T Tinderbox Regression Window:

Last Working Environmental Variables:
Device: Tarako
BuildID: 20140512105259
Gaia: 2d0e7005ef478ec59743dd0b44c0fa3ee3cbefa7
Gecko: 0d3b83e71186
Version: 28.1
Firmware: sp6821a_gonk4.0_user.pac

First Broken Environmental Variables:
Device:  Tarako
BuildID: 20140512115856
Gaia: 90b7f328526626072fa2eeb0664c9b3243b5a2af
Gecko: 56e7dd0eec94
Version: 28.1
Firmware: sp6821a_gonk4.0_user.pac

Last Working Gaia / First Broken Gecko: Issue does NOT occur.
Gaia: 2d0e7005ef478ec59743dd0b44c0fa3ee3cbefa7
Gecko: 56e7dd0eec94

First Broken Gaia / Last Working Gecko: Issue DOES occur.
Gaia: 90b7f328526626072fa2eeb0664c9b3243b5a2af
Gecko: 0d3b83e71186

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/2d0e7005ef478ec59743dd0b44c0fa3ee3cbefa7...90b7f328526626072fa2eeb0664c9b3243b5a2af
Caused by bug 1006987.

Alive - Can you take a look?
Blocks: 1006987
Flags: needinfo?(alive)
Component: Gaia::Gallery → Gaia::Homescreen
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Taken first
Assignee: nobody → alive
Flags: needinfo?(alive)
triage: 1.3T+ regression
blocking-b2g: 1.3T? → 1.3T+
Duplicate of this bug: 1012524
Whiteboard: [sprd313265][partner-blocker]
I think this is rather a gecko issue. It looks like the animationend/transitionend is losing so no app changes transition state to opened...
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #9)
> I think this is rather a gecko issue. It looks like the
> animationend/transitionend is losing so no app changes transition state to
> opened...

Furthermore: this will only happen when homescreen is killed at background.
I comment at bug 1012524:
 This issue is caused by the following method 'windowOpened' in window_manager.js:

if (!TrustedUIManager.isVisible() && !FtuLauncher.isFtuRunning()) {
        // Set homescreen visibility to false
        HomescreenLauncher.getHomescreen().setVisible(false);
      }

->When the homescreen is killed in background by LMK,here 'HomescreenLauncher.getHomescreen().frame' is null,this causes error when 'setVisible(false)'.For this issue,we could modify it as follows:
-->
if (!TrustedUIManager.isVisible() && !FtuLauncher.isFtuRunning()) {
        // Set homescreen visibility to false
        var homescreen = HomescreenLauncher.getHomescreen();
        if(homescreen.element)
          homescreen.setVisible(false);
      }

or -->
  if (!TrustedUIManager.isVisible() && !FtuLauncher.isFtuRunning()) {
        // Set homescreen visibility to false
        HomescreenLauncher.getHomescreen(true).setVisible(false);
      }
(In reply to yang.zhao from comment #11)
> I comment at bug 1012524:
>  This issue is caused by the following method 'windowOpened' in
> window_manager.js:
> 
> if (!TrustedUIManager.isVisible() && !FtuLauncher.isFtuRunning()) {
>         // Set homescreen visibility to false
>         HomescreenLauncher.getHomescreen().setVisible(false);
>       }
> 
> ->When the homescreen is killed in background by LMK,here
> 'HomescreenLauncher.getHomescreen().frame' is null,this causes error when
> 'setVisible(false)'.For this issue,we could modify it as follows:
> -->
> if (!TrustedUIManager.isVisible() && !FtuLauncher.isFtuRunning()) {
>         // Set homescreen visibility to false
>         var homescreen = HomescreenLauncher.getHomescreen();
>         if(homescreen.element)
>           homescreen.setVisible(false);
>       }
> 
> or -->
>   if (!TrustedUIManager.isVisible() && !FtuLauncher.isFtuRunning()) {
>         // Set homescreen visibility to false
>         HomescreenLauncher.getHomescreen(true).setVisible(false);
>       }

Yes, thanks for investigating.
Yet another window manager bug.
Attachment #8426035 - Flags: review?(timdream)
Attachment #8426035 - Flags: review?(timdream) → review+
Yang, please land to v1.3t.
Flags: needinfo?(yang.zhao)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #13)
> Created attachment 8426035 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/19457
> 
> Yet another window manager bug.
Hi,Alive
   Seems the Travis failed.Could you help to check it?Thank you.
Flags: needinfo?(alive)
Well, it's already merged. But I don't think the error is coming from the patch. If someone disagree please backout and reopen.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(alive)
Resolution: --- → FIXED
v1.3t commit:7af70c86a633d77cefc4e1b859e42d36df1d6320
Flags: needinfo?(yang.zhao)
Verified on the latest Tarako build

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

1.3 tarako: The Gallery app opens without any issues
You need to log in before you can comment on or make changes to this bug.