Closed Bug 1009728 Opened 7 years ago Closed 2 months ago

Implement "Close Tabs to the Left" as a built-in feature

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: Eduard.Braun2, Assigned: Eduard.Braun2)

References

Details

Attachments

(1 file)

We have implemented "Close Tabs to the Right" in bug 866880.
The logical next step is to also implement an option to "Close Tabs to the Left".

Actually closing tabs to the left might be even more useful than closing tabs to the right:
- In a normal workflow one opens new tabs to the right and
  reads them left to right
- This means read tabs are on the left, unread tabs are on the right.
- One possibly would not want to close unread tabs in this situation
  (close tabs to the right)
- However one would want to close read tabs if they are not needed anymore
  (close tabs to the left)

Another scenario where "Close Tabs to the Left" is more useful than "Close Tabs to the Right":
- Assume you have browsed before and minimized/closed Firefox with pages
  of this session still opened
- You start a new session (e.g. by following a link somewhere) and
  maximize/start Firefox again.
- After having opened some tabs in the new session, you realize you still
  have the pages of the old session (which will be to the left) opened
  but you don't need them anymore.
- You would want to "Close Tabs to the Left" of the first tab of the
  new session.
See Also: → 866880
I disagree with the usefulness of "close tabs to the left" (ctl). In fact, over time I've become skeptical at the usefulness of "close tabs to the right" (ctr), however ctr also matches parity with Chrome.
"Close Tabs to the Left" should definitely be an built-in feature. Especially now with the limited Add-On API where there is no way to put this option in the right position in the Context-Menu as an Web-Extension.

Also a common workflow is to pin Tabs like RSS-Reader, Mail, etc. which opens new tabs to the left of every existing tab which you want to keep open usually.

Side note why is all the most used stuff like closing tabs way down in the context menu by default? Makes absolutely no sense.
You might like the add-on FoxyTab. Obviously adding items to the context menu is not free. It’s already becoming quite overloaded. At a certain point (a dozen?) it becomes unwieldy. Do we have any data on which items are even being used?
Flags: needinfo?(jaws)
bwinton may be able to get you the details about which menu items are used most. We could use those details for a bug that is focused on cleaning up the context menus overall.

I'm going to close this as wontfix though since the situation described in comment #2 is a workflow that is quite narrow and we haven't had many other requests for this feature in the four years since it has been filed.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
Sadly, no, I only have data for context menus in content, not in chrome…

New bug requesting the same thing: https://bugzilla.mozilla.org/show_bug.cgi?id=1146224

Considering extensions are crippled in a way that makes it impossible for them to actually extend Firefox in a reasonable way here and the (existing) items in question have been moved to a submenu adding "Close tabs to the left" should definitely be revisited.

With "Close Tabs to the Right" having moved into a submenu in r533105,
it's only logical to offer this functionality as well for having feature parity.

Assignee: nobody → Eduard.Braun2
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Attachment #9201619 - Attachment description: Bug 1009728,1146224 - Implement "Close Tabs to the Left" r?jaws → Bug 1009728, bug 1146224 - Implement "Close Tabs to the Left" r?jaws
Duplicate of this bug: 1146224
Type: defect → enhancement
Attachment #9201619 - Attachment description: Bug 1009728, bug 1146224 - Implement "Close Tabs to the Left" r?jaws → Bug 1009728 - Implement "Close Tabs to the Left" r?jaws
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29bb42ae7d0b
Implement "Close Tabs to the Left" r=jaws
Backout by cbrindusan@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/791ad465a0c8
Backed out changeset 29bb42ae7d0b for causing bc failures in browser_multiselect_tabs_close_tabs_to_the_left.js
Attachment #9201619 - Attachment description: Bug 1009728 - Implement "Close Tabs to the Left" r?jaws → Bug 1009728, bug 1146224 - Implement "Close Tabs to the Left" r?jaws
Attachment #9201619 - Attachment description: Bug 1009728, bug 1146224 - Implement "Close Tabs to the Left" r?jaws → Bug 1009728 - Implement "Close Tabs to the Left" r?jaws
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/539d6c25a60e
Implement "Close Tabs to the Left" r=jaws
Status: REOPENED → RESOLVED
Closed: 3 years ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Flags: needinfo?(Eduard.Braun2)
You need to log in before you can comment on or make changes to this bug.