Filter is not migrated on linux

VERIFIED WORKSFORME

Status

MailNews Core
Profile Migration
--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: ji, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 09/21 branch and trunk build
OS: RH6.2-J and RH 7.1-J

Filters defined on 4.x are not migrated at all. 

Steps to reproduce:
1. Launch 4.x.
2. Define some filters, so far I tried movemail and delete filter.
3. Migrate the profile.
4. Open the filter on Mail window, the filter list is empty, none of filters are
migrated.

Updated

17 years ago
QA Contact: esther → laurel
(Reporter)

Comment 1

17 years ago
This problem can be reproduced on 09/07 branch build.

Comment 2

17 years ago
IMAP profile migrates filters OK for me using sep21 0.9.4 commercial branch
build, linux rh6.2.  Will try a POP...

Comment 3

17 years ago
POP profile migrates OK with filters (in filter list and also rules dialog
contains the exiting criteria) for me with linux rh6.2 and 0.9.4 commercial
sep21 branch build.
(Reporter)

Comment 4

17 years ago
IMAP filter migration doesn't work for me. POP seems okay.
(Reporter)

Comment 5

17 years ago
I have two IMAP account, one has filter defined before and the other one 
doesn't have any existing filters . Filter migration from the former account is 
not working. But it works for the latter account after creating the filter on 
4.x and then migrating to the current build.

Comment 6

17 years ago
Can you attach your rules.dat for the one not working. 

Comment 7

17 years ago
Xianglan, is this a regression?
(Reporter)

Comment 8

17 years ago
No, this is not a regression, it also happens when migrating to NS 6.1.
Navin, there is no rules.dat in my .netscape directory. I can send you the
account name and passwd of the problematic IMAP account if you need.

Comment 9

17 years ago
There should be "mailrule", but looks like this may be specific to just one acct

Comment 10

17 years ago
Xianglan, rules.dat are under WinNT (windows)|Profiles|Application data|Mozilla
etc...
(Reporter)

Comment 11

17 years ago
Marina, this is a linux specific problem.
Navin, I see a very strange thing happened when migrating my IMAP accounts. On
4.x I switch between these two IMAP accounts, one is called iqax1 on nsmail-2
and the other one is located at our testing mail server "seamonkey". I cleaned
up my .netscape, .mozilla and nsmail directory under my home directory before
launching 4.x.  Then I set up a mail account using iqax1, this is "bad" account
with which I experience this problem.  

After migrating, I go to my profile directory under .mizilla. In ImapMail
directory,  I saw three directories created! They are: iqax1, nsmail-2 and
seamonkey.mcom.com. 
One is for iqax1, but it's empty, another one is nsmail-2, which is the sever
name that holds iqax1 account. In nsmail-2 directory, rules.dat only contains
two lines: Version="8"  and logging="no". 

It seems to me mozilla is using nsmail-2 directory for mails of iqax1 account.
Since there is no rules.dat saved in nsmail-2 directory, so the migrated filter
list is empty.
(Reporter)

Comment 12

17 years ago
On above comments, I said "Since there is no rules.dat saved in nsmail-2
directory, so the migrated filter list is empty", it should be read as " Since
there is no data about 4.x filters saved in rules.dat file under nsmail-2
directory, so the migrated filter list is empty".

(Reporter)

Comment 13

17 years ago
And although there are three directories  generated in ImapMail directory under
the migrated profile, on account manager window, only one account shows: Mail
for iqax1@nsmail-2.

Comment 14

17 years ago
So, I'm confused from all the comments:  
1.  You DO have a mailrule file in your 4.x IMAP mail server directory (not in
.netscape, but usually (default) in home directory under ns-imap) with rules
specified in that file?
2.   The mail filters DO show for the (first) IMAP account in the 4.x UI? 

Comment 15

17 years ago
Using today's branch build I just successfully migrated a multiple IMAP server
profile from 4.x -- both imap servers' filters appear properly in the 6.2 ui.
(Reporter)

Comment 16

17 years ago
My bad, I didn't clean up ns-imap directory before migrating the profile, and
that ns-imap contains some wrong info about iqax1 account.
After I clean up ns-imap, filters can migrate properly.

Comment 17

17 years ago
So, this is a worksforme?
(Reporter)

Comment 18

17 years ago
Yes. Thanks.

Comment 19

17 years ago
Worksforme. Verified with sep24 commercial branch build.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 20

17 years ago
.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.