Closed Bug 10099 Opened 21 years ago Closed 21 years ago

HTTP REFERER not implemented.

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Windows 95
defect

Tracking

()

VERIFIED DUPLICATE of bug 1582

People

(Reporter: fede, Assigned: pollmann)

References

()

Details

This page take to a Perl script that let site's visitors to send URLs via email.
This script (called birdcast.pl) has a nice feature that prevent "parasitic" use
(i.e. called form offsite). For example, in this case script works only if it's
called from domain http://www.numerozero.com or http://numerozero.com.

When I try to submit data to this script it say me that can't complete my
request because it appear that is called from a non valid URL (not
numerozero.com). When I try with other browser, Netscape 4.6 or IE, script works
without problems.

I'm using Windows 95 4.00.950.b and apprunner build ID 1999071417
Assignee: karnaze → pollmann
Reassigning to Eric.
The problem will be because Mozilla currently doesn't send details of the
referring page (HTTP_REFERER) therefore the script will not know where the
script was called from.
Summary: form does not accept data with apprunner → HTTP REFERER not implemented.
This is likely something that needs to be implemented in the webshell or some
similarly scoped object.  CC'ing people who might be interested.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Marking duplicate.

*** This bug has been marked as a duplicate of 1582 ***
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.