Wrong letter "S" is added to Cyrillic Serbian (sr-Cyrl) keyboard

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nulti.korisnik, Assigned: flod)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

This is present in v1.3 and v1.4 (Gecko-baf2d97 Gaia-3f0cd80) on keon builds.

How to produce it:
- Select "Српски" (Serbian Cyrillic) in keyboard languages list;
- WIth Serbian keyboard, open any app that allows input and shows keyboard layout.

Note: I painted "S" on screenshots for better visibility.


Actual results:

There was extra "S" in the list (latin letter)


Expected results:

There should be no letter "S" at all.
Component: General → Gaia::Keyboard
Yep, the "S" is definitely there.

Francesco, do you know who can work on this? Because there's nothing we (Vanja and me) can do.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(francesco.lodolo)
I can try to help. In this case, you only want to hide the letter "S", right?
Flags: needinfo?(francesco.lodolo)
Posted image Keyboard without 'S' (obsolete) —
This is how the keyboard looks on master without S
Yes, that should be it. There is no "S" in Cyrillic so it shouldn't be there. Thanks.
Assignee: nobody → francesco.lodolo
Screenshot of the resulting key above.
Attachment #8429850 - Flags: review?(rlu)
Comment on attachment 8429850 [details] [review]
Pull request on Github

If we really need to remove this key, we should also adjust the key width for the 'Shift' key and Backspace key.

--
Besides, I could see this 'S' key appear on the Android stock keyboard.
Could someone on this bug confirm if it is ok to remove this key?

Thank you.
Attachment #8429850 - Flags: review?(rlu)
Aleksandra,

May I know your opinion about why 'S' key is present on Android's Serbian keyboard?
Thank you.
Flags: needinfo?(auzelac91)
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to Rudy Lu [:rudyl] from comment #8)
> Aleksandra,
> 
> May I know your opinion about why 'S' key is present on Android's Serbian
> keyboard?
> Thank you.

Hi, Rudy.

Honestly, I have no idea why it's present on Android or any other keyboard because there's no use for that character in Cyrillic. It simply doesn't exist, so it's pretty safe to remove.
Flags: needinfo?(auzelac91)
(In reply to Rudy Lu [:rudyl] from comment #7)
> If we really need to remove this key, we should also adjust the key width
> for the 'Shift' key and Backspace key.

I'd also need some directions on how to that, I searched around but couldn't find other examples.
(In reply to Francesco Lodolo [:flod] from comment #10)
> (In reply to Rudy Lu [:rudyl] from comment #7)
> > If we really need to remove this key, we should also adjust the key width
> > for the 'Shift' key and Backspace key.
> 
> I'd also need some directions on how to that, I searched around but couldn't
> find other examples.

If I understand correctly, each line has 10 keys. Since en.js uses 7+2, it has ratio 1.5 on shift and backspace.

sr-Cyrl is already using 8 characters, what should I change?

P.S. setting the bug back to NEW. It could be a WONTFIX, but definitely not unconfirmed, since I've received the same request from 3 different people.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Francesco Lodolo [:flod] from comment #11)
> P.S. setting the bug back to NEW. It could be a WONTFIX, but definitely not
> unconfirmed, since I've received the same request from 3 different people.

It is not WONTFIX. I dont wanna sound like a broken record but that character is non existant in the cyrillic alphabet so it has to be removed. If it stays there, what is the point of localization and different keymaps when you wont listen and coordinate with native speakeras about their rules and their customs? Would you put "đ" or "吉" into English keyboard?

p.s. Not trying to start a flame or war, just trying to make a point because this is present for a while and it should be fixed.
Posted image android_sr-cyrillic_keyboard.png (obsolete) —
Example of Cyrillic keyboard on Android device (AOSP keyboard, not custom one)
What do we need to do to move this bug forward?
Flags: needinfo?(rlu)
I think to adjust the key width, we should add ratio: 1.5 to the [Shift] and the [Backspace] key.
Please refer to this for an example,
https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/layouts/sr-Latn.js#L26

--
Sorry for not noticing your comments earlier, I only could reply to the bugs that I am ni'ed (needinfo).
So, thanks for keeping me posted.
Flags: needinfo?(rlu)
Posted image Updated keyboard
Attachment #8429426 - Attachment is obsolete: true
Attachment #8433288 - Attachment is obsolete: true
Comment on attachment 8429850 [details] [review]
Pull request on Github

Updated pull request, after trying I realized why you asked to set the ratio.
Attachment #8429850 - Flags: review?(rlu)
Comment on attachment 8429850 [details] [review]
Pull request on Github

Looks good to me. r+.
Thanks for patching this up.
Attachment #8429850 - Flags: review?(rlu) → review+
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/d9bd6c65d7a236eedaa190d1f6d1222192701d02

--
Thanks.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.