Prolog serialized in epilog for documents that are document.load()ed

RESOLVED DUPLICATE of bug 98788

Status

()

RESOLVED DUPLICATE of bug 98788
17 years ago
12 years ago

People

(Reporter: hjtoi-bugzilla, Assigned: hjtoi-bugzilla)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

This is what happens in a nutshell: if you have an XML document that contains
something in prolog, and you load that document with document.load(), then
serialize it with XMLSerializer, the prolog is serialized in the epilog. This
does not happen if you load the document with XMLHttpRequest.

A quess to the reason might be that for some reason we end up using HTML
serializer, which messes up with the prolog. Haven't debugged this yet.

There is a testcase in the tree under mozilla/content/xml/tests/load, but I will
also attach a testcase.
Doh, I had filed this earlier...

*** This bug has been marked as a duplicate of 98788 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.